We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SMTP send: The server committed a protocol violation

Last Friday, I created a new thread:


<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”>Posted By: peterhuppertz in Aspose.Email Product
Family

Subject: [SMTP] The server committed a protocol violation. The server response
was: Enter mail, end with “.” on a line by itself’. The link to that topic was
<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”><a href="
<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”>
I can see in my email that Kashif responded to this. However, the thread appears to have disappeared. :-o
<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”>Therefore, I open this new topic to breathe life back into the issue.
<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”>
<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”>My question was (and is) as follows:
We
have a situation wherein, on one particular host, while using Aspose.Email to
send a message via SMTP, the client throws an error stating:


<span style=“font-size: 9pt; font-family: “Segoe UI”, sans-serif; background: white;”>The server committed a
protocol violation. The server response was: Enter mail, end with “.”
on a line by itself’.<o:p></o:p>

On a different SMTP host in the same network, running the code works just fine.

I've written some test code, which is in the attached file

TestAsposeEmail.zip (I took the license files out).
This program outputted a couple log files, which are attached in

testAsposeEmailLogs 24-04-2017.zip


The file SmtpTest.log contains the actual exception thrown by the "offending" system.

The file called Aspose.Email.SMTP_2017-4-24.log is a text file that echos the SMTP dialogs. The first half is the dialog as conducted by the system on which the dialog fails (10.13.10.60); the second part (172.16.4.83) is the working system.

What puzzles me is what would trigger the protocol violation exception in the first dialog - I don't see anything wrong there.

Kashif then responded the same day, as follows:

I have tested this issue using my test account credentials and observed no issue. It seems to be specific issue with your server settings. I have shared the log files with my product team and will write back here as soon as some feedback is received.

I'm not amazed that you could not replicate this, as I myself have been unable to replicate the behaviour here. I would be interested to know what specific situation or setting could cause this behaviour to occur, as the SMTP dialog itself, including the response that the server coughs up, seems to be perfectly valid.

Regards,

Peter



Hi Peter,

Thank you for your inquiry and concerns.

You can access your old post using the link given below. Furthermore the log files have been shared with the product team. We will write back here as soon as we receive some feedback from the product team.

https://forum.aspose.com/t/15326

If I click that link, I get

Not Found: Forum Not Found

The forum you requested does not exist.

Hi Peter,


This seems to be some temporary glitch as I have tried this link many times and found it working all the time. Please give it a try again and share the feedback.

If it is temporary, it has not subsided yet. I am unable to see this thread - same result.
Luckily, I did get Kashif’s reply in email as well… I just cannot reply to it.

By the way, if I click the link


<span style=“font-size:12.0pt;font-family:“Times New Roman”,serif;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:NL;mso-fareast-language:
NL;mso-bidi-language:AR-SA”><a href="

in the reply, the URL changes to


Hope this helps,
Peter

Hi Peter,


This is strange as I have just clicked on the above link and it takes me to the page as shown in the attached image. You may please try clearing the browser cookies etc. and check it again. Otherwise you may check out some other system as well as there is no issue in this link. Please give it a try and share the feedback.

I am unable to access. Its same error as reported by Peter H

Hi,


I am afraid that this issue is not re-produced here. I can open the link without any error. Please try it on some different systems after performing the steps mentioned above.

I am using different computer and from different network too, and I have not access the same url before. So in my case this link should open.

Hi,


We can still open the other thread at our end. May be cleaning your browser cookies/cache may help access the thread. Also, please logout and login to see if it can make a difference.

Any update on this. We are still unable to open the link. Can you please open the thread



Hi,


Can you please try it now? It should open fine now at your end as well.