We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Spell checking

attached is my project.
my issue:
in word 365, I have these options set:
image.png (2.0 KB)
on my .dotx template, I have a table, and the review settings are set like this:
image.png (22.8 KB)

however, after I generate the table, the settings look like this:
image.png (18.3 KB)

and no spell checking squigglies are displayed in the table.
spellcheck.zip (28.1 KB)

@conniem

We have tested the scenario using the latest version of Aspose.Words for .NET 19.10 and have not found the shared issue. So, please use Aspose.Words for .NET 19.10.

We suggest you please check the spell check setting of mail merge field instead of whole table and then output data in output document.

I am using aspose.words for .net 19.10.

checking the template, on the merge field,
image.png (13.3 KB)
checking the output, on the merge field:
image.png (14.5 KB)

@conniem

We have tested the scenario and have not found the shared issue at our end. We have checked the input and output documents in MS Word 2016 with the same setting that you have. We have attached the screenshots of input and output documents with this post for your kind reference.

Input document:

Output document:

interesting.
I open the test.dotx file, and look at review | language option, and look at this specific field (because it’s a text field, not a date field):, and the check is cleared
image.png (25.5 KB)
and the output shows that it is set

@conniem

We have not found the different language settings in input and output documents at our end using MS Word 2016. We suggest you please select the whole field in input document, set the same language setting, and perform the mail merge operation. Hope this helps you.