We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SpreadsheetML (.xml) file to XLSX data filters and sorting are not working in .NET

Hi,

We’re converting SpreadsheetML file to xslx. See example input attached.
Worksheet has ss:Protected=“1” attribute, but also has AllowFilter element inside . We would expect cells to be protected but still allow filtering. Can you please take a look?

Thanks,
Maciek

Filtering3.zip (1.2 KB)

@acturisaspose,

Thanks for the template file and details.

After an initial test, I observed the issue as you mentioned by converting your template SpreadsheetML (.xml) file to XLSX via Aspose.Cells APIs. I found that filters are not working in the output XLSX (SpreadsheetML to XLSX conversion):
e.g
Sample code:

Workbook workbook = new Workbook("e:\\test2\\Filtering3.xml"); 
            workbook.Save("e:\\test2\\out1.xlsx", SaveFormat.Xlsx) ;

I have logged a ticket with an id “CELLSNET-45548” for your issue. We will look into it soon.

Once we have an update on it, we will let you know here.

Thank you.

@acturisaspose

Thanks for using Aspose APIs.

This is to inform you that we have fixed your issue CELLSNET-45548 now. We will soon provide the fix after performing QA and including other enhancements and fixes.

@acturisaspose

Thanks for using Aspose APIs.

Please download and try the following fix and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-45548) have been fixed in latest version of Aspose.Cells for .NET (Download | NuGet).

Hi

I tested and for option AllowFilter this is working fine but it still ignore AllowSort. Please could you take a look at this.

..
<Worksheet ss:Name="Test" ss:Protected="1">
...
<WorksheetOptions>
...
<AllowSort>True</AllowSort>
<AllowFilter>True</AllowFilter>
...
</WorksheetOptions>
...

Thanks

@acturisaspose,

Thanks for providing us some details.

When I manually open your “Filtering3.xml” file into MS Excel and then save it as XLSX file format. I also cannot perform sorting upon the data manually in MS Excel for the output XLSX file. Even I cannot perform data sorting for your source SpreadsheetML file too as it is protected.

Do you use some other source SpreadsheetML file, if so, kindly share that file, we will check it soon.

Hi

Example in attachment AllowSort.zip (94.5 KB)

Thanks

1 Like

@acturisaspose,

Thanks for providing us template file.

After an initial test, I am able to reproduce the issue as you mentioned by converting your new template SpreadsheetML (.xml) file to XLSX via Aspose.Cells APIs. I found that data sorting is not working in the output XLSX (SpreadsheetML to XLSX conversion), SpreadsheetML’s AllowSort element doesn’t work anymore:
e.g
Sample code:

Workbook workbook = new Workbook("e:\\test2\\AllowSort.xml"); 
            workbook.Save("e:\\test2\\out1.xlsx", SaveFormat.Xlsx); 

I have logged a separate ticket with an id “CELLSNET-45683” for your issue. We will look into it soon.

Once we have an update on it, we will let you know here.

@acturisaspose,

Thanks for using Aspose APIs.

This is to inform you that we have fixed your issue CELLSNET-45683 now. We will soon provide the fix after performing QA and including other enhancements and fixes.

@acturisaspose,

Please try our latest version/fix: Aspose.Cells for .NET v17.9.4.

Your issue “CELLSNET-45683” should be fixed in it.

Let us know your feedback.

Hi,
As we don’t have a process to download files from Dropbox, could you please confirm when will this be released?

@acturisaspose,

The next official release of the product, i.e., Aspose.Cells for .NET will be published in the third or fourth week of October, 2017. We can also post you the fix via email, so kindly provide your email id here.

The issues you have found earlier (filed as CELLSNET-45683) have been fixed in Aspose.Cells for .NET 17.10.