We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SSRS CSV Export Encoding

Hello,
I have the Aspose.Cells installed on SSRS2008 (not R2).
When using the CSV Via Aspose.cells option, Chinese characters are exported as question marks.
How can I export these characters properly?

Ran

Hi,

Could you post your sample RDL file and exported Excel file here, we will check your issue soon.

Thank you.

Hi,

We have received your sample RDL, CSV files etc. via email. We will look into your issue and get back to you soon here.

Thank you.

Hi ,

Please modify encode parameter for CSV rendering in Aspose.Cells.ReportingServices.xml file, refer to the following context:

=======================================





=======================================

Other parameters : ASCII,BigEndianUnicode, Unicode,UTF32,UTF7.

The Aspose.Cells.ReportingServices.xml file is in ${Aspose.Cells for Reporting Services installation folder} folder.

Thank you.


Hi,

I’ve changed the encode value tag to “UTF8” or any other Unicode option but it still does not export it properly.

I should I do next?

thanks,
Ran



Hi ,

Please post your Aspose.Cells.ReportingServices.xml file here and confirm us the following information

  • Aspose.Cells for Reporting Services version.
  • The path value of key (HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Aspose\Aspose.Cells.ReportingServices or HKEY_LOCAL_MACHINE\SOFTWARE \Aspose\Aspose.Cells.ReportingServices).
  • Runtime environment.
  • SQL Server base settings. E.g. character set.


We will check it ASAP.

Hello,

The xml and answers are bellow

<?xml version="1.0" encoding="utf-8"?>




































  • Aspose.Cells for Reporting Services version is: 1.6.0.0
  • The registry value is C:\Program Files (x86)\Aspose\Aspose.Cells for Reporting Services</li>
  • The report is embedded in an Asp.Net page via Reportviewer, but it doesn’t work even if I try it directly on the SSRS reportserver
  • The SQL Server settings where the SSRS repository in is:
    The Collation is SQL_Latin1_General_CP1_CI_AS and the Language is English (United States).
Thanks,

Ran

Hi,

Thanks for providing us the details.

I have logged your issue into our issue tracking system with an id: CELSSREP-22987. Once we figure it out, we will let you know.

Thank you.

Hi ,

We had tested for the issue. But we do not find the issue.

We provide the demo sample to reference. The local report is embedded in an Asp.Net page via Report Viewer.

If the issue stills exist , please post your web project . We will check it ASAP

Sorry, I didnt get where is the provided sample ?

Ran

Hi,

Please find it attached now.

Thank you.

Hi,
I got some compilation errors when I tried to build the project.
Anyway, I don’t think that this issue relates to the ASP.NET page, as I get he same result also when exporting a CSV from the SSRS server directly. The file I get is an ANSI file whereas the file I get from the Microsoft CSV export is a UTF-8 file. It also happens at the SSRS demos on your website (http://www.aspose.com/demos/ssrs-rendering-extensions/pages/folder.aspx?ItemPath=%2FAdventureWorks+2008+Sample+Reports&ViewMode=List)

Ran

Hi ,

Do you support East Asian Languages in your server? If not, please try installing files for East Asian Languages on your server. Let us know if it works.

Thank you.

Yes we do have the east asian languages package installed on the server.

I have a few questions

  1. We didn’t install yet the license we purchased, it is only on a test server can it be the cause?
  2. After editing the Aspose XML file, do I have restart something (e.g. the RS service, Server?)
  3. It would be great if we will do a remote session so you’ll be able to check everything you need. Can we do that?

Ran

Hi,

1. You do not need to install the license file.
2. You do not need to restart RS Service and Server.
3. You may add "roywangt@gmail.com" id to your messenger list and chat us in between 9.00 -5.00pm (local time in China)…

Does your client PC has the east Asian languages package?



Thank you.

Yes, My client PC has the East Asian languages package too.
How can I make sure that a change in the Aspose xml file actually applies?

Hello,
After the chat with Roy, I realized that the CSV file I get from the Aspose export is an ANSI file (he sent me an exported file). Therefore I’ll be able to see Chinese properly only if the Windows encoding for non Unicode characters of the server is Chinese. I cannot get a CSV file encoded as Unicode even when the Aspose xml file is configured to render CSV this way. Please change your Windows encoding for non Unicode characters to English and see if you can read properly a Chinese CSV file.
Can you please send me an exported file encoded as Unicode?

Thanks

Hi,

Thank you for your support.

We had found the issue and fixed it.

Please try the fixed version Aspose.Cells for RS 1.6.0.4

Please copy Aspose.Cells.ReportingServices.dll into following folder :

{SQL Server 2008 Reporting Services installation folder }\Reporting Services\ReportServer\bin .
And modify encode parameter at Aspose.Cells.ReportingServices.xml file.





The encode parameter only support CSV and Txt format.

Hi,

We recommend you to use our latest official version v1.7.0, you may download it here:
http://www.aspose.com/community/files/52/ssrs-rendering-extensions/aspose.cells-for-reporting-services/entry286476.aspx

Thank you.

Hi,

Do you still face this issue?