.STL to .Drc created but not loading

Hi, Am to trying save .STL as .drc File , but when .drc 3D file is created but it’s not loading as 3D file it says file is corrupted. Please help… Am i missing anything ? am new to Aspose.

Error Image in UI (21.4 KB)
image.png (3.8 KB)

string MyDir = @“C:\drccOutput”;
DracoSaveOptions opts = new DracoSaveOptions
CompressionLevel = DracoCompressionLevel.Fast
Scene scene = new Scene();
scene.Open(MyDir + “C26938.stl”);
// Save Google Draco (.drc) file
scene.Save(MyDir + $“DRCSaveOptions_out{DateTime.Now.ToString(“MMDDYYYYHHSS”)}hD.drc”, opts);


Thank you for contacting support.

Would you please share source and generated ZIP files so that we may try to reproduce and investigate it in our environment. Before sharing requested data, please ensure using Aspose.3D for .NET 19.4.


We have investigated it further and have been able to reproduce it in our environment. Therefore, a ticket with ID THREEDNET-504 was logged, which has been resolved in Aspose.3D for .NET 19.5. Please upgrade to latest version and then share your kind feedback with us.

Thanks so much… it’s working now.

Hi @Farhan.Raza , Am trying to convert back.DRC to .STL it was working fine with below code but now suddenly it’s not working, not sure why it is broken.

Please help.
Aspose Nuget Version - 19.7.0

.DRC -->.Ply -->.STL (It was working)

       //Stl to Drc 
        Scene stltodrcScene = new Scene();
        stltodrcScene.Open(@"C:\Output\Input.stl", FileFormat.STLBinary);
        stltodrcScene.Save(@"C:\Output\Input2.drc", new DracoSaveOptions { CompressionLevel = DracoCompressionLevel.Optimal });

        //Drc to PLY
        Scene drctoplyScene = new Scene();
        drctoplyScene.Open(@"C:\Output\Input2.drc", FileFormat.Draco);
        drctoplyScene.Save(@"C:\Output\Input3.ply", new PlySaveOptions(FileContentType.Binary) );

        //PLy to STL
        Scene PlytoStlScene = new Scene();
        PlytoStlScene.Open(@"C:\Output\Input3.ply", FileFormat.PLY);
        PlytoStlScene.Save(@"C:\Output\Input4.stl", new STLSaveOptions(FileContentType.Binary));

        // Drc to STL (Direct)
        Scene drctoStlScene = new Scene();
        drctoStlScene.Open(@"C:\Output\Input2.drc", FileFormat.Draco);
        drctoStlScene.Save(@"C:\Output\Input5.stl", new STLSaveOptions(FileContentType.Binary));

Note: This happened after license applied.


Thank you for getting back to us.

Would you please share some more details about the issue. Are you getting some exception or the generated file is not fine. Kindly share some sample files with us as ZIP so that we may investigate further and assist accordingly.

@Farhan.Raza - I have attached the input and output files…InputStl.zip (5.9 MB)
Ouput Ply-stl.zip (2.9 MB)
OutPut Drc - STL Direct.zip (49.1 KB)
Output stl-drc-ply.zip (4.8 MB)

I have converted STL to DRC and when I tried to convert back DRC to STL now the stl file is broken,
Initially, it was working fine with Converting DRC to PLY to STL but now this also totally broken it not converting back same as STL file.


Thank you for sharing requested data.

We had found a problem in STL exporter which has been fixed now. We have created a hotfix for this so please test and then share your kind feedback with us.

Aspose.3D for .NET 19.7.1.zip

@Farhan.Raza - I tried with 19.7.1 version, but still I am facing the same issue.


It appears like there may be some problem on your end only. Kindly create a sample application containing SSCCE code so that we may investigate further. Also share your license file with us by clicking on my username and then message icon.

@Farhan.Raza - Attached complied code DRCtoSTL_Issue.zip (1.2 MB)

Sorry, Due to company policies, I am unable to share the Licence expect basic details.

We doubt the issue happening while STL to DRC or STL to PLY to DRC


Thank you for sharing the data.

We are checking it and will get back to you soon.


We would like to inform you that we are working on resolution and will share the fix tentatively in about a week. Please be patient and spare us little time.

We are sorry for the inconvenience.


Any luck on the fix …


We are working on it and will let you know as soon as the ticket will be resolved. We really appreciate your patience in this regard.


Thank you for being patient.

We are glad to inform you that the issue has been resolved. Please try attached hotfix and then share your kind feedback with us.

Aspose.3D for .NET 19.7.3

@Farhan.Raza Facing the same issue…Could you please share sample code which is working or SSCCE code.


We are collecting details and will get back to you shortly.


We have attached sample project for your kind reference. DRCtoSTL_Issue.zip

To run this project, unzip it and execute below commands in the extracted directory:

  • dotnet restore
  • dotnet run

It will download the Aspose.3D for .NET 19.8 from NuGet server and convert the 3D file, We have double checked the 3D models and found all of them to be correct. You may find the converted 3D models here for your reference.

@Farhan.Raza - Thanks… It is working.