Free Support Forum - aspose.com

Strange issue with LEFT function

Not sure this has happened to anyone else but I am using a pricing model built in Excel that used the LEFT function without giving the number of characters. It did not work. When I added a comma and one it then worked. LEFT(Named_Range) doesn’t work for me. LEFT(Named_Range,1) worked fine. I am using the latest version.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

Latest Version:
Aspose.Cells
for .NET v7.3.3.
2

Please provide us your source and expected output files and sample code replicating your issue with the above latest version.

We will check your issue at our end. If we find, it is a bug, we will log it in our database so that it could be fixed.

We have also tested your issue in detail by creating the attached source file and using the following code. Everything works fine. LEFT(Named_Range) does not cause any issue at all.

I have also attached the screenshot for your reference. Please also see the Debug Output of this code.

C#


String filePath = @“F:\Shak-Data-RW\Downloads\source.xlsx”;


Workbook workbook = new Workbook(filePath);


Worksheet worksheet = workbook.Worksheets[0];


Cell c1 = worksheet.Cells[“C1”];


//Returns ‘s’

Debug.WriteLine("StringValue: " + c1.StringValue);


//Change the text of cell A1

worksheet.Cells[“A1”].PutValue(“another text”);


//Use this value to make sure your formulas are recalculated

workbook.CalculateFormula();


//Returns ‘a’

Debug.WriteLine("StringValue: " + c1.StringValue);

Debug Output:
StringValue: s
StringValue: a

Screenshot: