We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SVG to PDF Issue

Hi,

Any idea why the attached SVG is not getting converted to PDF properly?

Thanks,
Sampath

Hi Sampath,


Thanks for your inquiry. I have tested the SVG to PDF conversion with Aspose.Pdf for .NET 10.4.0 and unable to notice any issue. Please download and try latest version of Aspose.Pdf for .NET, it will resolve the issue. If issue persist then please share your sample code, output PDF document and environment for further investigation. We will look into it and guide you accordingly.


Best Regards,

I am actually using this to convert a web page (that has the attached SVG images) to PDF. With the new version (10.4.0), I am getting the following error when trying to convert the file (using HtmlLoadOptions) -

‘clip-path’ is an unexpected token. The expected token is ‘=’. Line 414, position 2015.

Any idea how to resolve this?

Hi Sampath,


Thanks for your feedback. We will appreciate it if you please share your sample code and HTML here, we will look into it and will provide you information accordingly.

We are sorry for the inconvenience caused.

Best Regards,

PFA the html i was trying to convert to HTML. You can see that the html file has an svg chart. If I extract that to a separate svg file and convert that to PDF using SvgLoadOptions it works fine. But when i try to convert the attached html to PDF it is throwing an error.

Hi Sampath,

Thanks for sharing the sample HTML document. I have tested your scenario with shared document using Aspose.Pdf for .NET 10.4.0 and managed to observe the reported issue. For further investigation, I have logged an issue in our issue tracking system as PDFNEWNET-38728 and also linked your request to it. We will keep you updated via this thread regarding the issue status.

Please feel free to contact us for any further assistance.

Best Regards

Could you also take a look at the attached SVG and let me know why is the PDF file that is getting generated has some random lines in it?


Thanks,
Sampath

Hi Sampath,


Thanks for your inquiry. We have noticed the reported random lines issue in SVG to PDF conversion, so logged a ticket PDFNEWNET-38732 in our issue tracking system for further investigation and resolution. We will let you know our findings as soon as its investigation is completed.

We are sorry for the inconvenience caused.

Best Regards,

Any ETA on this issue? The previous version of Aspose.pdf seems to handle this properly. The issue seems to be specific to the newer version (10.4.0)

Hi Sampath,

Thanks for your inquiry. I am afraid your issue are still not resolved as we have recently noticed the reported issue and it is still pending for investigation due to other issues, already under investigation and resolution. We will notify you as soon as we made some progress towards issue resolution.

Moreover, we have logged HTML to PDF issue as regression issue in system, because it was working in 10.3.0 but 10.4.0. And it will be treated with high priority.

We are sorry for the inconvenience caused.

Best Regards,

FYI - the issue seems to be with any empty style attributes (eg.,
style=""). For now, I am just replacing this with an empty string
before using aspose to convert the html string to PDF. Hope this helps
with your troubleshooting/fixing the issue.

Hi Sampath,

Thanks for sharing your findings. We have passed it to our product team, they will consider it while investigating the issue. We will notify you as soon as we made some significant progress towards issue resolution.

Thanks for your patience and cooperation.

Best Regards,

The issues you have found earlier (filed as PDFNEWNET-38728) have been fixed in Aspose.Pdf for .NET 10.8.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan

The issues you have found earlier (filed as PDFNET-38732) have been fixed in Aspose.PDF for .NET 19.12.