We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

System.InvalidCastException: 'Unable to cast object of type 'Aspose.Words.Drawing.Shape' to type 'Aspose.Words.Paragraph'.'

We are getting this error while using the product at writing
Document doc = new Document(“path_of_template”);
System.InvalidCastException: ‘Unable to cast object of type ‘Aspose.Words.Drawing.Shape’ to type ‘Aspose.Words.Paragraph’.’

We are using product version 16.10.0.0 with .NET Core application. However its working fine with -Version 19.10.0

Please help to solve this issue

@jai_intellisims_com

Please note that we do not provide support for older released versions of Aspose.Words. Moreover, we do not provide any fixes or patches for old versions of Aspose products either. All fixes and new features are always added into new versions of our products.

We always encourage our customers to use the latest version of Aspose.Words as it contains newly introduced features, enhancements and fixes to the issues that were reported earlier.

So, please use the latest version of Aspose.Words for .NET 19.11.

Hi Tahir,

Thanks for quick response.
When we are using with newer version. It showing error with licensing as
The subscription included in this license allows free upgrades until 08 Dec 2017, but this version of the product was released on 01 Nov 2019. Please renew the subscription or use a previous version of the product.
How to proceed from here?

@jai_intellisims_com

Please get 30 days temporary license from the following link to check this issue.
Get a Temporary License

Please post your query in Aspose.Purchase forum to renew your license.

Hi Tahir,

So we will receive updated copy of license and replace temp license with updated license right?

@jai_intellisims_com,

Unlike the Temporary License, regular License is not free; please refer to Aspose.Words for .NET Pricing Information page.

Yes, the problem occurs because your license has expired. Please contact our sales team to get an updated license file. Then the updated license file will allow you to use the latest version of Aspose.Words. And yes, you need to replace Temporary License with the updated license. For any more details, please refer to Aspose.Words Licensing page.