Free Support Forum - aspose.com

Task.Notes field is not text (2.7.0.0)

I'm using the latest build 2.7.0.0 which is supposed to have fixed a bug where the notes field comes out in an RTF format. This is still happening. I have a notes fields with little more than 'this is notes' and it comes through looking like Chinese.

Is there something I'm missing?

Hi,


The issue is still not resolved. You can find some issue’s discussion as well as some workarounds in this and in this forum threads .

I have linked the issue ‘Parse a plain text from Notes RTF data.’ with ID = 16279 to this forum thread, so you’ll get a notification about the issue resolution automatically from our corporate issue tracking system.

Sorry for inconvenience.

The issues you have found earlier (filed as 16279) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

I’ve just tested the v3.0.0 which claims to have resolved this. This still doesn’t work as I’d expect. I’m just looking at task.Notes property. It is still chinese. Is there something else I need to do to look at the Notes property. I’ve attached my single task test example with one line of basic notes.

Hi,

Did you try the two readonly properties...

.NotesRTF

to get RTF or

.NotesText

to get Text.

Regards, Bruce

Hi,

Yes, we have introduced two additional properties in Task class: NotesRTF which reads the RTF notes and NotesText which extracts the plain text from Notes RTF data.

Thanks and Regards

The issues you have found earlier (filed as ) have been fixed in this Aspose.Words for JasperReports 18.3 update.