We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Test project grid disabled

Hi,

I have tried to create a test project to illustrate some issues I am having with the Grid.

I am not able to get the grid working at all in the test project.

I feel that I have set it up as well as I know how, but the grid is disabled on the page.

Everything shows up fine, but nothing is clickable or editable.

Test Project Attached.

Hi,

Thanks for the project you have posted.

Since you are using MS Ajax extensions in your project, we will look into your issue soon.

In the mean time, could you try to place the GridWeb outside of the UpdatePanel and check if it works fine.

Thank you.

Doesn't the Aspose Grid Support Ajax?

I have it working in an ajax environment on the main project. This is just a test project to try to demonstrate another problem.

I have removced the update panel from the page, same problem still exists.

New source attached.

Hi,

Yes, it works on MS Ajax environment.

Thanks for providing us further details, we will look into your issue soon.

Thank you.

Hi,

Well, it looks strange as the GridWeb works fine on your main project in Ajax environment, but not on that particular env. Could you try to compare the two environments and map which different configurations you are setting on that machine/server. Which IIS settings and browser type etc. you are using as well. We will also try to figure it out soon.

By the way since you are also using some older version of Aspose.Grid.Web, we recommend you to try our latest version as well: http://www.aspose.com/community/files/53/visual-components/aspose.grid/entry126616.aspx

Thank you.

Yes it is working successfully in our AJAX site as well, this is a test site I have set up to illustrate a different problem in topic http://www.aspose.com/community/forums/147045/datasource-empty-after-paste/showthread.aspx#147045

The configuration, environment and platform are the same, both projects are on the same machine using the same browser.

I have copied the grid over from one project to the other with settings the same.

I have tried it with our existing license, and in evaluation mode.

I hvae tried it with and without ajax.

Rod

Hi Rod,

Well, it looks really odd as GridWeb works in one project but not in other. Anyways, we will check your issue thoroughly and let you know soon.

I think may be you can also try and create a fresh project on some other machine to check if it works there.

Thank you.

I recreated the project in a web application instead of web site and it works fine now.

It appears to be related to the virtual directory used in a web site??

So the problem is not corrected, but it doesn't effect me any more.