We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Text are missing after converting XLSX to PDF

Hi,

I want to convert an xlsx file into PDF. However, there were some labels missing after the conversion. I tried to convert the same xlsx file online with Aspose online service and the texts were there. I don’t know if there is an opinion to print those missing texts. Please advise

		String dataDir = "./abc/";
	Workbook book = new Workbook(dataDir + "budget.xlsx");
	SaveOptions saveOptions = new PdfSaveOptions();
	saveOptions.setWarningCallback(warningInfo -> {
		if (warningInfo.getWarningType() == WarningType.FONT_SUBSTITUTION) {
			System.out.println(warningInfo.getDescription());
		}
	});
	book.save("./abc/budget.xlsx.pdf", saveOptions);
	System.out.println("ConvertWorksheetToImageByPage executed successfully.");

System information

  • Aspose Cells Java: 20.7
  • Openjdk 14.0.1 2020-04-14
  • MacOS Catalina 10.15.3

Input/output files
Archive.zip (975.5 KB)

@tmhungtrilogy,
I have tried your sample code and observed that titles were missing. After further investigation, it was revealed that Century font is not installed on my system. I installed missing font from this link and then again tried the sample code. This time the output PDF was correct as titles were found in the PDF. You may please give it a try and share the feedback.
aspose-cells-20.8.2.zip (7.0 MB)
Century_Regular.ttf.zip (29.9 KB)
budget.xlsx.20.8.2.pdf (74.9 KB)