Text formats removed when using template method


#1

If I include formatted text in a single cell not cell formatting e.g. Call A1 contains ‘This is some sample text.’ when your component populates the worksheet it comes out like this. ‘This is some sample text.’ with all of the formatting removed.

Is this unsupported or is there something else I need to do.

If it’s currently unsupported is it possible to support?[^o)]

P.S. Like the new forum format, and the performance has improved aswell…[:)]


#2

Currently Aspose.Excel doesn’t support to set different text formats in a single cell at run time. However, if you set them in the designer spreadsheet, Aspose.Excel supports it.


#3

I am setting them in the designer and not manipulating the text in those fields at all via code but the resulting file has the text format removed. I can send you samples to illistrait. I’m using Aspose.Excel ver 2.2.1.0.


#4

Please email me the samples. My email address is nanjing@aspose.com. Thank you.


#5

I will forward the files to you.

More Info: I realised I forgot to mention one thing. I am copying the excel worksheet within the document a number of time and then removing the original template worksheet. I dont know if this makes any difference.


#6

I got your files. Thanks.

After investigating it, I found it’s caused by your coping worksheets. We will try to find the way to totally support various text format in a single cell. But now could you try to add extra worksheets in your designer spreadsheet and remove the unneeded sheets at run time?


#7

This issue is also solved in the latest hotfix. Please try it.


#8

Works fine. Thanks…Big Smile