Free Support Forum - aspose.com

Trouble installing

Hi, I'm having a problem installing Aspose.Words.4.4.2.0. I downloaded the MSI file and saved it to c:\temp\Aspose.Words.4420.msi. I started the installer file... After awhile I get "The feature you are trying to use is on a network resource that is unavailable."

"Click OK to try again, or enter an alternate path to a folder containing the installation package 'Aspose.Words.msi' in the box below." So I enter c:\temp\Aspose.Words.4420.msi again. I then get ... "The file 'C:\temp\Aspose.Words4420.msi' is not a valid installation package for the product Aspose.Words. Tryo to find the installation package 'Aspose.Words.msi' in a folder from which you can install Aspose.Words."

I hit Cancel. I get "The older version of Aspose.Words cannot be removed. Contact your technical support group." I click OK. I get "The installer was interrupted before Aspose.Words could be installed. You need to restart the installer to try again." Tried several times. Tried with different filename for the installer, in a different location. Tried rebooting and tried again. No luck.

Any ideas?


This message was posted using Email2Forum by Merit.

Hi

Thanks for your inquiry. Try first to remove older version of Aspose.Words and then run installation. Could you please provide me information about your system configuration?

Also I attached Aspose.Words.dll v4.4.2.0.

Best regards.

Thanks for attaching the DLL, which is the main thing I wanted.

I did also try uninstalling the old version first using the "Add or Remove Programs" feature in the Control Panel, and got a similar error, if I recall. Is there any way to explicitly remove the old version, including registry editing? I know, it's dangerous.

I'm on Windows XP, with plenty of memory and disk space available.

The old version of Aspose is on my C: drive in the default location.

Hi

Try renaming your msi file. New name should be “Aspose.Words4420.msi” or “Aspose.Words.msi”. May be this will help.

Best regards.

I’ve tried renaming it to Aspose.Words.msi, but that didn’t work.

Hi!
Try renaming, archiving or moving somewhere the entire folder
C:\Program Files\Aspose\Aspose.Words.
Then install the new version. Don't delete old one before you are sure everything works fine.
Regards,

I've tried that too. I've also tried running a registry cleanup program.

I'm about to try running the registry cleanup program after renaming the Aspose.Words folder again.

I’m afraid that didn’t work either. For what it’s worh Aspose.Words still shows up in Add/Remove Programs, but there’s no Delete button there.

Hi

Also you can try reinstalling (repairing) older version of Aspose.Words and then install the latest version.

Best regards.

<o:p></o:p>

I tried that, with the same result.

HOWEVER, I finally managed to install it successfully. I think the problem may have been that with previous installations I had selected the option to install for "everyone that uses this computer", and this time I had selected for "myself". Setting it to install for "everyone that uses this computer" allowed the installation to be successful.

I hope that this record of the error messages I saw helps anyone else that runs into the problem.

Regards,
Steve

journeymansix, you siad you finally managed to install it successfully but didn't explain how. Please let me know, I'm practically fed up here trying to get a new version of Aspose.Words to insta.. Thanks!