Free Support Forum - aspose.com

Trouble with "ActuallyUsed" mode from "ExtractImageMode"


#1

Hello,

We’re considering getting a newer version of Aspose.PDF and many things seems to have changed drastically. We build a prototype with the free demo (version 18.10) and succeed in doing what we wanted to do which is extracting all barcodes from a document. To do so, we want to find every image visible to the reader. To do that, we used the propriety “ExtractImageMode”, but had to set it at “DefinedInRessources”, because “ActuallyUsed” (the one we used before) doesn’t seem to work anymore. It didn’t find any image in each pdf we tried it on.

Are you having trouble with the “ActuallyUsed” mode or is there a paticuliar way to use it now? Is it a restriction on the free demo (evaluation mode)?

Like i said before, we only need to extract the barcodes that are visible to a reader or printable.

Have a nice day.
David


#2

@RFUser

Thank you for contacting support.

Please note that you may request for a free 30 day temporary license to test the APIs in full capacity. Moreover, please share sample PDF document along with narrowed down code snippet which works with Aspose.PDF for .NET 18.10 but not with latest version. We will try to reproduce and investigate it in our environment.


#3

Hello @Farhan.Raza,

Is there a way to send you the sample code in private message. We would like to keep the information that it contains to as few people as possible.

And there seems to be a misconception, the actual version is not 18.10 but much older. Our demo was with the 18.10 version (it was the latest one then).

Have a nice day
David


#4

@RFUser

Please note that the attachments are accessible to thread owner and Aspose Staff only so you may share the files here. Or you may upload these to Google Drive, Dropbox etc. and then share download link with us privately through a message by clicking on my username. However, please ensure using Aspose.PDF for .NET 19.1 in your environment.


#5

We tried with the 19.1 version in our environment and we still have the problem. I have attached the logs from our prototype and the documents with the codebar. I’m trying to upload the projets but it doesn’t seems to work. Is there a limit on the size of the upload?

pdf.zip (1.8 MB)
logs.zip (3.1 KB)


#6

@RFUser

Please note that the upload limit for forums is around 5MB so the narrowed down sample application can be shared via Google Drive, Dropbox etc and download link can be shared as private message by clicking on my username. Once you send the message, please acknowledge here for reference.