Free Support Forum - aspose.com

Trying to set license with net core 2


#1

We recently upgraded our licence and are trying to use it on net core. We were using it on asp net 4+ before.

When I first tried to set the licence, it was erroring because it did not like 1252 encoding as this isn’t supported in net core by default.

Trying the methods suggested here.

http://www.aspose.com/corporate/purchase/license-instructions.aspx

Now when I try and set the license using the stream method, or file method or embedded resource, they all fail with this error.

System.Reflection.AmbiguousMatchException: ‘Ambiguous match found.’

Can you give me some advice how to get this to work?

Thanks.


#2

@stonecourier,

Thanks for your inquiry. Please share your license file via private message. In order to send a private message with attachments, please click on my name and find “Message” button. (see steps). We will investigate the issue on our end and provide you more information. Please do not share your license file publicly in this thread.


#3

It looks like I don’t have permissions to message you yet. This forum account is very new.


#4

@stonecourier,

We have updated your account’s permissions. You should now be able to see/use this private Message option.


#5

@stonecourier,

Thanks for sharing your license file via private message.

I am afraid, your license file worked fine on our end when using Aspose.Words for .NET 18.7. We have prepared a simple console application (see DotNetCoreApp.zip (753.2 KB)) to test your license. Before running the application, please copy your license file in “~\DotNetCoreApp\bin\Debug\netcoreapp2.0\” folder.


#6

A post was split to a new topic: Sample Dot Net Core App that uses Aspose.Words for .NET