We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Ul tag support in image

attachment is my sample code



it seems, it didn’t support ul tag when save to image ? or I didn’t set font folder directly ?



it works fine when I transfer it to word.

Hi Alan,

Thanks for your inquiry. Perhaps, you are using an older version of Aspose.Words; as with Aspose.Words v15.6.0, I am unable to reproduce this problem on my side. I would suggest you please upgrade to the latest version of Aspose.Words i.e. v15.6.0 and let us know how it goes on your side. I hope, this will help.

Hi Tahir

I’m using Aspose.Words v15.6.0 still have this bug

is there any configuration will effect this ?

Hi Alan,

Thanks for your inquiry. It would be great if you please share following detail for investigation purposes.


  • Please attach your input Word and Html document.
  • Please

    share a runnable simple Java application that demonstrates the code (Aspose.Words code) you used to generate
    your output document

  • Please attach the output Word file that shows the undesired behavior.

Unfortunately,
it is difficult to say what the problem is without the Document(s) and
simplified application. We need your Document(s) and simple project to
reproduce the problem. As soon as you get these pieces of information to
us we’ll start our investigation into your issue.

Hi ,

thanks for your reply, be honesty my code is the same with sample code, nothing different



I’m using mac OS X

and I include the symbol.ttf and wingding.ttf

to my custom path, and also set the fontFolder path

it still not work,

the weird thing is, if I change the ul tag type to square, it’s work

do you have any idea about that ?



i’m using ruby java bridge to include the jar file

and wrote the code in ruby.

I will test in writing native java code

if it’s still the same I will paste the java code to you



thanks

Hi,

attachment is my java code

it has the same problem

because the fonts are too big, so I didn’t include it in the oltag folder



it’s the download link of my fonts



https://mega.co.nz/#!pUA2DRJB!DjYe0c7y1-3ZTSakSYSIfjS0p0nJEDc7K1u2V2ztnWQ



in my java sample code it still has the sample problem.

Hi Alan,

Thanks
for sharing the detail. Please note that Aspose.Words requires TrueType fonts when
rendering documents to fixed-page formats (JPEG, PNG, PDF or XPS). Make sure
you have all the Fonts installed on your machine you’re using to convert
Word document to PNG format.

I have copied all fonts from Windows system to Ubuntu and have tested the scenario at Ubuntu. I have not found the shared issue. I have attached the output PNG with this post for your kind reference.

I suggest you read about installing true type fonts on Linux operating system from here:
http://www.aspose.com/docs/display/wordsjava/How+to++Install+True+Type+Fonts+on+Linux

Hi Tahir



thanks for your reply,



I tried use windows and ubuntu version to run the

same code I provided to you, both of these for me, I didn’t copy symbol.ttf from windows, and it still work.



and I did follow the link you provided to copy the symbol.ttf and wingding.ttf to the mac /Library/Fonts folder



and it still not work for me in my mac computer .



do you have any idea about this ?

p.s. attachment are font I input to the OS X and the output

Hi Alan,

Thanks
for sharing the detail. I have also not found this issue at Ubuntu and Windows. I am setting up Mac system at my end and will update you about my finding asap.

Hi Alan,

Thanks
for your patience. I have tested the scenario at Mac operating system and have managed to reproduce the same issue at my side. For the sake of correction, I have logged this problem in our issue tracking system as WORDSJAVA-1123. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Thanks for your help

The issues you have found earlier (filed as WORDSJAVA-1123) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.