We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unable to create thumbnail from slide containing Do not autoscale textbox

Hello,

I’m having a strange issue, this was previously report in 510591.

When a slide contains a text box with 2 columns and set to ‘Do not autoscale’
AND text does not completely fit the text box size.
Code that never returns on GetThumbnail():

This problem still exists. It actually has to do with getting thumbnail from the slide in “Release” mode. When I run the same code in Debug mode, all works OK.

If you try this code, its very easy to reproduce. I am using version 15.10.0.0 of Aspose. But please remember to run it in Release mode.

Thanks
Anita

Aspose.Slides.Presentation pres = null;

//Create a new presentation based on a template.

pres = new Aspose.Slides.Presentation(“asposefile.pptx”);

System.Console.WriteLine(“File Opened”);

Aspose.Slides.ISlide[] slides = pres.Slides.ToArray();

Aspose.Slides.ISlide sld = slides[0];

System.Console.WriteLine(“About to Image…”);

System.Drawing.Image slide = sld.GetThumbnail(1, 1);

pres.Dispose();

pres = null;

Hi Anita,


Thank you for your interest in Aspose.Slides.

We are investigating the issue reported by you and we will get back to you with our findings, soon.

Best Regards,

Hi Anita,


I have worked with the data shared by you but I am unable to reproduce the issue. The attached thumbnail (see asposefile_Slide-1.jpg) is generated, in release mode, with out any issue. I request you to please try using the code as explained in this documentation article and Aspose.Slides for .NET 16.1.0 on your side and then share your kind feedback with us.

Please let us know if the issue persists. We will be pleased to assist you further.

Best Regards,