Free Support Forum - aspose.com

'Unable to get installer types' error when installing Aspose.Words

I get a strange error message when I try to install Aspose.Words on my pc - see attachment. I have Office 2007 on Windows XP Professional SP3. Is anyone familiar with this error?


Thanks,

D.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. To install and run Aspose.Words for Microsoft Word make sure you have the following software installed:

- .NET Framework 2.0 or newer

- Microsoft Office Word 2007 Service Pack 2

Hope this helps.

Best regards.

Hi Alexey,


Thank you for your reply. I already have .Net Framework 2.0 SP2 and later versions (3.0 SP2; 3.5 SP1) as well as Service Pack 2 of Office 2007 installed. I’m afraid the problem is somewhere else.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Could you please check version of MS Word. On my side it is

Microsoft Office Word 2007 (12.0.6425.1000) SP2 MSO (12.0.6425.1000)

Best regards.

I have some different numbers:


Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. It seems you have exactly the same environment as I have on my side: Windows XP SP3, .NET framework 2.0 installed and MS Office 2007 SP2. But I can successfully install Aspose.Words for MS Word on my side.

Maybe there are some problems with rights on your side. Have you tried installing under Administrator account?

Best regards.

Hi Alexey,


I tried to install as administrator but still get the same error message.

I think I’ll look for another solution; this error message is too vague to find out what causes the problem. Thanks for your help.

D.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Please let me know if you find a solution of this issue. This can help other customers, who might have the same problem.

You can also try running MSI installer with /lv flag as shown below:

msiexec /i Aspose.Words.MicrosoftWord.msi /lv log.txt

Maybe log will be more helpful than error message.

Best regards.

Thanks, I did what you said. I’ve attached the log file.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. But unfortunately, I cannot find any useful information in the log. Maybe there is some software, which I need to install in order to reproduce the same problem on my side. IF so please let me know.

Have you tried installing Aspose.Words for MS Word on another PC? It is difficult to guess why this occurs on your side. It would be much easier if I can reproduce the problem on my side.

Best regards.