We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unable to get the Aspose jars from the mentioned URL through gradle build in Jenkins Job

Hi! Aspose Team,
Since morning we are not able to build our Spring boot project, because we are downloading the aspose jars from the mentioned URL.
Could you help us asap, because it is stopping our deployment.
URL: 'https://releases.aspose.com/java/repo/com/aspose/aspose-cells/21.7/aspose-cells-21.7.pom
URL: https://releases.aspose.com/java/repo/com/aspose/aspose-slides/22.8/aspose-slides-22.8.pom
thanks
Rohan Wankar

image.png (37.6 KB)

@Rohan_Wankar,
Please check your configurations for the Gradle project here:


Hi! Audrey
I am able to get the aspose cells jar when I click the mentioned url in the browser.
But not the aspose slides.
The configuration which we had for our project seems working fine till Friday.
From morning we are not getting the jars for aspose cells & aspose slides as well through jenkins job.

@Rohan_Wankar,
Could you please clarify where you got those URLs from?

Hi! @Andrey_Potapov
I have updated the url.
But I am also not sure about the issue.
Till friday all was working fine, but from Monday morning I am facing the issue, when I tried to rebuild my PR.
Not sure about the issue.
Could you check once I have updated the URL, we are using this URL to get the aspose jars while building the project locally or in an env.
Please take a look, it is blocking our deployment.
thanks!
Rohan Wankar

We got the links from here
Installation|Documentation (aspose.com)
Installation|Aspose.Slides Documentation

@Rohan_Wankar,
Your URLs are correct. Could you please share a simple project that reproduces the problem you are encountering?

Hi! @Andrey_Potapov
I don’t see any problem in building the project locally.
But when I tried with Jenkins build job,
there is no connectivity issue with the url, we are able to connect from Jenkins VM and aspose server, but we are not getting any response from the url mentioned from aspose server.
I confirmed with my Tech ops team and added the screenshot.
Please take a look on this at high priority & let me know for any suggestions for the issue asap.
Because it is blocking our deployment.
thanks!
image.png (28.7 KB)

@Rohan_Wankar,
Thank you for the error screenshot. My colleagues from Aspose.Cells team will reply to you soon.

@Rohan_Wankar,

We found the issue is related to hosting. Our concerned team is working over it and it will be figured out soon.

We are sorry for any inconvenience caused!

@Rohan_Wankar

Can you please check and verify as our hosting team has updated their ACL rules. Thanks.

thanks! @farooq.sheikh
But what was the actual issue for the problems.

@Rohan_Wankar,

The issue was related to firewall rules which were blocking certain traffic. We have fixed it now.

1 Like