Free Support Forum - aspose.com

Unable to use Mail Merge and Lock on word file

Several of our customers have had issues witht the following error. The attached file causes an error on Aspose.Word 3.3.0.0(The latest Version):
We are using MailMerge and ProtectDocument and get this error.
System Exception occurred Aspose.Word.PleaseReportException: Cannot find a footnote or an endnote for the specified position. For free technical support, please post this error and the file in the Aspose.Word Forums http://www.aspose.com/forums/ShowForum.aspx?ForumID=75. at ೦.ᄵ.ᅏ(Int32 ൿ, ੟ ೺) at ೦.ᄵ.ᅉ(Char ྖ, Int32 ൿ, ੟ ೺, ༺ ೻) at ೦.ᄵ.ᅂ(੟ ೺, ༺ ೻, ᅕ ᅀ, Int32 ࠎ, Int32 ۆ) at ೦.ᄵ.ᅁ(Int32 ೳ) at ೦.ᄵ.ᄿ(ᅕ ᅀ) at ೦.ᄵ.Ԉ(Int32 ᄾ, Int32 ۆ) at ೦.ᄵ.Ԉ() at ೦.೥.ۋ() at Aspose.Word.Document.Ֆ(Stream Ւ, String ৒, LoadFormat દ, String ܒ) at Aspose.Word.Document..ctor(String fileName, LoadFormat loadFormat, String password) at Aspose.Word.Document..ctor(String fileName) at Aspose.Asposeword.getDocument(String filePath)

I've traced this down to a somewhat invalid footnote or endnote in the document. I mean it does not comply with the way a footnote should be stored in the DOC file according to my knowledge, but now since I've seen how it can be, I've added code that handles this situation successfully. I will publish a hotfix in the next 1-2 days.

This is fixed in Aspose.Word 3.3.1

I still get this issue with the 3.3.2.0 version of aspose. I uninstalled and then re-installed the product.

I have tried to load your document using Aspose.Word 3.3.0.0 and exception appears.

When I use 3.3.2.0 the document loads ok.

Check Version property of Aspose.Word reference in Solution Explorer. It should be 3.3.2.0. If not -remove the reference and add it again.

The new version appears to fix the image problem and both the MailMerge and ProtectDocument calls appear to succeed. However, once the user opens the files on MS Word 2003, and scrolls down to where the images are shown, MS Word throws an exception and indicates that the document must be repaired. Any ideas on this one?

We have been able to reproduce the problem. Please allow several days for working out a fix or workaround.

This problem is caused by images grouped with textboxes into group shapes on page 6 of the document. This is for the both images. Aspose.Word has trouble dealing with textboxes in groups at the moment.

To workaround, click on the image, right click and select Ungroup. Then it would also be a good idea to click on each textbox and pull their anchors to different paragraphs. This will help to avoid Z-order being lost since if several shapes are anchored to one paragraph, Aspose.Word might lose their Z-order and you end up with some textboxes below the image.

All problems with textboxes, groups and z-order will eventually be fixed in Aspose.Word. It's just an issue that can't be fixed easily, requires some good work.

All problems with textboxes, groups and z-order are now fixed since we have implemented a new graphics engine in Aspose.Words 4.0. Please try running your application with the new version.