We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Uncheck Multi-level Category Labels

Hi Aspose support team

In my requirement, i have a chart. In the chart category axis, i need to uncheck the Multi-level Category Labels. But i cannot able to achive this feature throught the application. i have attached the screenshot for your kind reference. Could you please provide the sample piece of code to achive this feature.

Thanks in advance

Regards,
Saravanan

Hi,

Please also provide us your sample xlsx files which you can create manually using Ms-Excel so that we could load it using Aspose.Cells APIs and find out how to uncheck this box. If it is a new feature, we will report it to development team.

HI Support team,

Please find the attached excel for your kind reference. Right click in the category axis of the chart. NOw select the Format Axis. Now you can able to see the check box for Multi level category label. PLease provice the sample pice of code to achive this feature?

Thanks in advance

Regards,

Saravanan

Hi,

After initial investigation, I found, this is a New Feature. I have therefore logged a request so that it could be implemented.

This issue has been logged as CELLSNET-40010.

Hi,


Please try the new fix: Please download: Aspose.Cells for .NET v7.0.2.1. We have added a new property:

workbook.Worksheets[0].Charts[0].CategoryAxis.HasMultiLevelLabels


Thank you.

The issues you have found earlier (filed as CELLSNET-40010) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Hi Support team,

Thanks for this update.

I have faced another one issue releated to this property.Now i cannot able to check the check box of Multi-level Category Label.

I have used the following code :

obj.ExcelWorkBook.Worksheets[0].Charts[0].CategoryAxis.HasMultiLevelLabels = true;

I have attached the Multi_Level_Category_Labels.jpeg for your kind reference.

Please help me to check the check box of Multi-level Category Label.

Thanks

Saravanan

Hi,


I have tested with v7.0.3, it works fine with your template “Source1.xlsx” file you attached previously.
Here is my sample code:

Sample code:
Workbook ExcelWorkBook = new Workbook(“e:\test2\Source1.xlsx”);
ExcelWorkBook.Worksheets[0].Charts[0].CategoryAxis.HasMultiLevelLabels = true;
ExcelWorkBook.Save(“e:\test2\outBook.xlsx”);


If you have problem with other file, kindly attach it here, we can check it.

Thank you.

Hi Aspose Support team,

Thank you for the reply. Still i am not able to set the Multi-level Category Labels as true. i have attached the sample Project(solution) and the Multi-level Category.xlsx(For source, Please put this file in C drive).

In the sample solution, i have 4 excel sheets. 1.Data. 2.VSummary 3.PSummary 4.BP.

In the sheet Vsummary and PSummary, i am setting in the category axis property HasMultiLevelLabels as false(Line no 409, 489). It is working fine. (For verification goto Format axis of Category axis - the check box is not checked). Please refer the attached Multi_Level_Category_Labels_not_set.jpeg

In the sheet BP, i am setting in the category axis property HasMultiLevelLabels as true(Line no 613). It is not working.

Please let me know if you need additional information regarding this.

Thank you
Saravanan

Hi,


After an initial test, I can find the issue as you mentioned. I have reopened the issue. We need to investigate the issue. We will look into it and get back to you soon.

Thank you.

Hi,

We have fixed this issue. Please download:
Aspose.Cells for .NET v7.0.3.2