We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Undesired behavior of Worksheet.Move method

Hi,

I have attached one sample application. I am using ASPOSE.Cells version 4.8.1.4.

I have one excel file which is created in MS Excel2007(as .xlsx) but saved in the .xls format using Save as=>(97-2003 MS Excel format) option in MS Excel 2007. I have copied it into the bin/debug folder of sample applicaiton attached. This file contains two worksheets. "Summary" and "Data". The "Summary" worksheet contains cells having references(Cell.Formula feature) to data on "Data" worksheet.
Here if I insert one worksheet between these two worksheets using worksheet.Move method the references for cells on the "Summary" worksheet goes to the new worksheet. This is creating problem for me.
But this case is not happening if I create file on MS Excel 2003 and insert new worksheet on it.

I have spent lot of time in figuring out the problem but I am not able to succeed.
Please help ASAP.

Thanks
Devendra

Hi,

Thanks for providing us the sample project.

After an initial test, I can find the issue you have mentioned. I have logged your issue into our issue tracking system with an id: CELLSNET-18949. Once it is figured it out, we will provide you the fixed version.

Thank you.

Hi Amjad,

Thanks for the consideration.
Sorry to bother you guys but I need this fix ASAP.
Also it would be better if you provide me the fix on the same ASPOSE binary version (4.8.1.4). Since we are using this stable version in our product and would not like to test all the reports again.

Thanks for you help.

Regards
Devendra

Hi Devendra,

Well, we are working on your issue and will update you soon. Also, I am afraid, there is no way but to upgrade to use latest versions/fixes of the product. Moreover, a bug fix version can only be created based on the most latest version of the product, we cannot incorporate an change or functionality to some old versions/fixes at all as this is against or business policy (internal) and we cannot go against it.

Thanks for your understanding!

Hi,

Please try the attached version, we have fixed your issue now.

Thank you.

Hi Amjad,

Thanks for the fix. It's working fine now.

Regards
Devendra

The issues you have found earlier (filed as 18949) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.