We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unreadable content error in Excel 2013 after opening and saving xlsx file

Hello,


I have a problem with Excel (xlsx) file generated using Aspose.Cell library. The file is generated successfully and I can open the file without any error at first time. But after that if I save or save as the same file and open it again it will give me following error.

We found a problem with some content in ‘text.xlsx’. Do you want us to try to recover as much as we can? If you trust the source of this workbook, Click Yes.

If I click ‘Yes’ it will try to recover some content and give me following message.

Repaired Records: Drawing from /xl/drawings/drawing1.xml part

It seems that after repair, all my drawing and picture object are removed from the excel file.

I am using following piece of code to save the workbook with Aspose.Cells 8.6.3
workbook.Save(filename, SaveFormat.Xlsx);
I have tested the same scenario with Excel 2007 and it seems working fine so conclusion is that the error comes up with Excel 2010 or larger.
Can you please look into the issue and let me know what should I do to remove the error.
Thanks in Advance.

Hi Jaydeep,


Thank you for contacting Aspose support.

I am afraid, we cannot initiate the investigation unless you provide us an executable sample application along with the input & output spreadsheets to replicate the issue on our side. Before you move forward to provide us the above requested, please give a try to the latest revision of the API, that is; 8.6.3.5 at the moment. In case the problem persists with latest revision (attached), please provide us an executable demo application (as discussed above) for thorough investigation.

Thanks for quick reply!


Is nuget package available for v8.6.3.5?

Hi,


The fix v8.6.3.5 is an interim release but it will work fine on Production server, so you may use it without any issue. Well, we publish only official releases to Nuget repository. We are scheduled to release our next official version, i.e., Aspose.Cells for .NET v8.7.0 within the next few days (e.g a week or so) on Aspose site as well as NuGet rep., so kindly wait a bit (so you can pick your desired Aspose.Cells assembly for the underlying .NET framework version(s) in the packages). Furthermore, our next official release v8.7.0 would include the functionality of all the previous fixes including this one too.

Thank you.

Hi Amjad,

Thanks for providing details.

Babar has provided me the Aspose.Cells v8.6.3.5 for .NET 2.0, But actually I have used the Aspose.Cells for .NET v4.0 using the nuget package. Can you please provide me the Aspose.Cells v8.6.3.5 for .NET 4.0 so I can just replace it in nuget package directory and test further.

Also what is the tentative release date of Aspose.Cells for .NET v8.7.0 on nuget server so I can plan further. I hope updating the version will solve my original problem else I will provide you sample application with sample input and output file.

Thanks,
Jaydeep

Hi Jaydeep,


As narrated by Amjad in his last response that we only publish the major release over the NuGet repository which contains all assemblies compiled for different frameworks, whereas v8.6.3.5 is an interim release shared with concerned threads only. We are currently preparing the next official release of Aspose.Cells for .NET 8.7.0 for publication, which is expected in next week so we request you to wait for a couple of days (hopefully 4~5) in order to test your scenario with the aforementioned release.

Thank you for your understanding & cooperation.

Thanks Babar,

I understand the concern. What I was asking is to provide Aspose.Cells v8.6.3.5 for .NET 4.0. The attached dll of Aspose.Cells v8.6.3.5 is for .NET 2.0


Hi Jaydeep,


We do provide the interim releases compiled on specific .NET Framework on special requests, however, as we are currently preparing the next build of Aspose.Cells for .NET 8.7.0 for publication, fulfilling your requirement may delay the process, that is the reason we have asked you to wait for a couple of days, if possible.

I have tried the same with Aspose.Cells 8.7.0 version but still getting the same error while opening an edited excel file.

Hi,


We are sorry that you are still facing the issue. As we told you earlier, we cannot initiate the investigation unless you provide us sample project (runnable) along with the input & output spreadsheets to replicate the issue on our side. Also provide a demo video (you may capture it demonstrating the scenario) to show what steps are involved to reproduce the issue on our end, so we could log an appropriate ticket into our database.

PS. Please try our latest version/fix: Aspose.Cells for .NET v8.7.1.4 if it makes any difference.

Thank you.