Free Support Forum - aspose.com

Unsupported major minor version when calling the PDFLicense class

Hi


I am using aspose-pdf-kit-3.8.0.jar on an IBM J9 1.5 environment and I keep getting this error message when calling or setting the PDF license using the PDFLicense class.

Exception in thread “main” java.lang.UnsupportedClassVersionError: (aspose/pdf/License) bad major version at offset=6

If I run the same code on an IBM J9 1.6 it works no problem.

Here is the exact version of the IBM JDK:

java version "1.5.0"
Java™ 2 Runtime Environment, Standard Edition (build pwi32devifx-20110208a (SR12 FP2 +IZ94331))
IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223ifx-20101008 (JIT enabled)
J9VM - 20101007_66049_lHdSMr
JIT - 20100623_16197ifx1_r8
GC - 20100211_AA)
JCL - 20110208

I have read that the jar should be compatible with 1.4,1.5 and 1.6 JDK’s.

Please assist.

Thanks


Hi Liwies,

I would like to share with you that you can use Aspose.Pdf.Kit for Java with JDK 1.4, 1.5, and 1.6 alike. However, if you’re having problem in some particular scenario then we’ll have to further investigate it. Could you please share code snippet you’re using at your end? Also, please elaborate how you’re trying to use the license in your application. We’ll investigate it at our end and update you accordingly. If we require any further information from your end, we’ll let you know.

We’re sorry for the inconvenience and looking forward to help you out.
Regards,

Hi


Below is the code I am using - the scenario is the first post on the this thread but to make sure I will explain again.

I am running the below code inside a IBM J9 1.6. Your support team says that the jar file is comptible with JavaVM 1.4,5,6 however when I run this code which is compiled for Java 1.5 on the IBM J9 1.5 JDK I get the major minor error. When I run the same code on a IBM J9 1.6 the code executes with no problems.



p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Monaco} p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Monaco; min-height: 15.0px} span.s1 {color: #941965} span.s2 {color: #3e38f5} span.Apple-tab-span {white-space:pre}

boolean isValid = false;


PdfFileInfo fileInfo = new PdfFileInfo(pdfIn.getAbsolutePath());


String application = fileInfo.getCreator();


if (application.equalsIgnoreCase("e@syScan"))

{

isValid = true;

}


return isValid;



Thanks

Hi Liwies,

Thank you very much for sharing further details. We’ll investigate this issue in detail and update you accordingly. Please spare us some time for further investigation.

We’re sorry for the inconvenience.
Regards,

Hi Aspose

It has been a month since the last post and I want to find out if this bug has been fixed yet?
The application is now live and we have clients that are experiencing this exact issue.
Please can you provide a timeline or the fix itself so I can manage the expectation of the client.

Thank you

Liwies

Hi Liwies,

I have logged this issue as PDFKITJAVA-28368 in our issue tracking system. We need to investigate it in detail in order to find the cause of this issue and then resolve it. I’m afraid, we’re unable to share any timeline for the resolution of this issue at the moment. We’ll keep you updated with the status of this issue.

We’re sorry for the inconvenience.
Regards,