We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

UnsupportedFormat exception on loading PPT (Java)

sample.ppt.zip (138.5 KB)
Aspose Slides not able to open PPT presentation and reports the following error:

class com.aspose.slides.PptUnsupportedFormatException: Unknown file format. —> class com.aspose.slides.exceptions.Exception: Can’t read a record data (4 byte(s) missing
Record: public, Header:RecordHeader, Type:0xFF6 [RT_CurrentUserAtom], Version:0, Instance:0, Length:0x1C
Offset: 0x0008
com.aspose.slides.internal.mv.fj.do(Unknown Source)
com.aspose.slides.internal.mv.fj.for(Unknown Source)
com.aspose.slides.internal.mv.public.do(Unknown Source)
com.aspose.slides.internal.mv.e5.int(Unknown Source)
com.aspose.slides.Presentation.int(Unknown Source)
com.aspose.slides.Presentation.do(Unknown Source)
com.aspose.slides.Presentation.do(Unknown Source)
com.aspose.slides.Presentation.(Unknown Source)
com.aspose.slides.Presentation.(Unknown Source)

@thomas.winklehner,

I have worked with the presentation file shared by you using Aspose.Slides for Java 20.1 on my end and have not been able to reproduce the issue. Please try using the shared version on your end.

saved.pdf (158.8 KB)

Thank you. Updating to version 20.1 resolved the issue.

@thomas.winklehner,

It’s good to know that suggested version has worked on your end.