We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unwanted tag is included after HTML to RTF conversion using .NET

Why does the RTF generated using Aspose.Words has a blank backgroung image code.

{*\background{\shp{*\shpinst\shplid1025\shpleft0\shpright0\shptop0\shpbottom0\shpfhdr0\shpz0\shpfblwtxt0\shpbxcolumn\shpbxignore\shpbypara\shpbyignore\shpwr3\shpwrk0{\sp{\sn fLayoutInCell}{\sv 1}}{\sp{\sn fLineOK}{\sv 0}}{\sp{\sn fillColor}{\sv 16777215}}
{\sp{\sn fFilled}{\sv 1}}{\sp{\sn lineWidth}{\sv 0}}{\sp{\sn fLine}{\sv 0}}{\sp{\sn fFlipH}{\sv 0}}{\sp{\sn fFlipV}{\sv 0}}{\sp{\sn shapeType}{\sv 1}}{\sp{\sn fBackground}{\sv 1}}}{\shprslt\par\pard{\pict\jpegblip}\par}}}

Is there a way to tell Aspose to not add this code to RTF file. Some of our clients are getting error when they try to import the RTF file containing this code.

@parulagg

To ensure a timely and accurate response, please attach the following resources here for testing:

  • Your input document.
  • Please attach the output RTF file that shows the undesired behavior.
  • Please attach the expected output RTF file that shows the desired behavior.
  • Please create a standalone console application ( source code without compilation errors ) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we will start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.