We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Urgent Issue: Conversion of Excel file to PDF failed

I tried converting the excel file to PDF with old Aspose components(licensed version 4.7.1.0) but it is not even able to open the file. I am get following exception when trying to open that file with Aspose.Cells.

Destination array out of range

at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.BitConverter.ToInt16(Byte[] value, Int32 startIndex)
at System.BitConverter.ToUInt16(Byte[] value, Int32 startIndex)
at Aspose.Cells.RW.x8b6071c5dcbbf539.x9af9735afe1963bd(x508b33aea0611cd1 xcf18e5243f8d5fd3)
at Aspose.Cells.RW.x8b6071c5dcbbf539.xbddc206c7dafc24d(x508b33aea0611cd1 xcf18e5243f8d5fd3)

I tried converting the same file using newer version of Aspose components(4.9.0.0). I was able to open the file but was not able to convert it. I get the following exception

Rounding digits must be between 0 and 15, inclusive.
Parameter name: digits

at xf1e06fd8be9d8c69.x19af241ea5d0fb76.x0acd3c2012ea2ee8(String xafe2f3653ee64ebc)
at Aspose.Cells.Workbook.Save(String fileName, FileFormatType fileFormatType) .

Please provide fix for this issue as soon as possible. Reply me on vpatel@intralinks.com or call on 617-648-3518 if you need anything else.

Hi,

Please try our latest version/fix v5.0.0.13.

If you still find any issue, I am afraid, we need your template Excel file to test the conversion, so you need to post/attach your sample file here to reproduce the issue.


Thank you.

I downloaded and tested with latest version of Aspose.Cell (5.1.0.0). But still I am getting following exception: Please reply back asap if you able to fix below given exception. We need this fix urgently. Because of security concerns we cannot provide that excel file. I guess following stack trace should be sufficient for you:

Aspose.Cells.CellsException was caught
Message="Index was out of range. Must be non-negative and less than the size of the collection.\r\nParameter name: index"
Source="Aspose.Cells"
StackTrace:
at xf1e06fd8be9d8c69.x19af241ea5d0fb76.x0acd3c2012ea2ee8(String xafe2f3653ee64ebc)
at Aspose.Cells.Workbook.Save(String fileName, FileFormatType fileFormatType)
at Intralinks.Common.Utilities.AsposeConverter.ConvertXlsToPdf(String sourceFilePath, String destinationFilePath) in C:\WSB\ILD3.6\IntralinksSolution\CommonUtilities\AsposeConverter.cs:line 95
at Intralinks.Common.Utilities.CommonUtilities.ConvertOfficeDocsToPDF(String sourceFile, String destinationFolder) in C:\WSB\ILD3.6\IntralinksSolution\CommonUtilities\CommonUtilities.cs:line 1276
InnerException:

Hi,

Well, your mentioned error “Index was out of range. Must be non-negative and less than the size of
the collection…” has multiple scenarios so, we cannot find the root cause of the issue. I am afraid, we need your template file to trace the issue.

Please click the check box “Keep this post private” (while replying us), doing so, now only you and Aspose staff members would see your posts/thread, no other users could see or download your attachments.

Alternatively, you can mail us your template file, please follow the below mentioned steps:

1: click the Contact button in the Post

2: In the drop down list options click "Send Amjad Sahi an Email”.

3: Attach the template files and send it (you may zip the file prior attaching it).

4: Once you have done it, kindly confirm us here in this thread.


Thank you.

Please find attached sample excel file for your test. Please let me know the failure reason and when will be the fix available.

Hi,

We have found an issue converting your template file to PDF. We will figure it out soon.

I have logged your issue with an id: CELLSNET-18564.

Thank you.

As this is very urgent issue and major breakage for the application. So it would be better if you can send me the failure reason and planned release date for this fix.

Hi,

We will check if we can provide you an eta for the fix, we will get back to you soon.

Thank you.

Hi,

We will provide you the fix within 2-3 days.

Thank you.

Hi,

The problem is fixed in new release version 5.1.1. Please download it from http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry250805.aspx and try using it. We are sorry for this problem.