We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Use Aspose.PDF Cloud SDK for PHP with for > PHP 7.2

Hi, Team,

I have tried Aspose.PDF Cloud SDK for PHP. It seems it will not work for > PHP 7.2 because, while running the “composer Install” command I am getting the following error:

Your lock file does not contain a compatible set of packages. Please run composer update.

Problem 1

- friendsofphp/php-cs-fixer is locked to version v1.13.3 and an update of this package was not requested.

- friendsofphp/php-cs-fixer v1.13.3 requires php ^5.3.6 || >=7.0 <7.2 -> your php version (7.3.24) does not satisfy that requirement.

And once run the “composer update” then get the following error:

Your requirements could not be resolved to an installable set of packages.

Problem 1

- friendsofphp/php-cs-fixer[v1.12.0, …, v1.13.3] require php ^5.3.6 || >=7.0 <7.2 -> your php version (7.3.24) does not satisfy that requirement.

- Root composer.json requires friendsofphp/php-cs-fixer ~1.12 -> satisfiable by friendsofphp/php-cs-fixer[v1.12.0, …, v1.13.3].

Let me know if you have any solution for this, I have to complete my POC before moving ahead.Your quick help will be highly appreciated.

This topic has been moved to the related forum: https://forum.aspose.cloud/t/use-aspose-pdf-cloud-sdk-for-php-with-for-php-7-2/14841