Free Support Forum - aspose.com

Using Aspose.word with Visual Web Developer 2005 Express and .Net 2.0

Hello,

I've downloaded the evaluation package for Aspose.Word and I'm having trouble actually using it in a .NET 2.0 Beta 2 project. The evaluation also came with Aspose.pdf, barcode, etc etc. When I add the reference to Aspose.Word, it places the reference to the aspose.word.dll file and the aspose.word.xml file - but then nothing is recognized when I type "using Aspose.Word;" I get the message:

Error 2 The type or namespace name 'Word' does not exist in the namespace 'Aspose' (are you missing an assembly reference?) F:\\WebSite1\Default3.aspx.cs 11 14 F:\WebSite1\

The dll is in my bin folder. When I do the same exact procedure for Aspose.pdf or Aspose.barcode it works fine. Any ideas?

Thanks

Hi,

Thank you for your interest in Aspose.Word.

Have you also tried to use fully qualified names:

Aspose.Word.Document doc = new Aspose.Word.Document()

Do they work? If not, please post your source code.

Hi, that is the thing, Visual Web Developer isn’t recognizing the aspose.word.dll at all (for some reason, though it does recognize the other ones just fine) even though it had no problem adding the reference to the project.

After creating a new web project, all I add is the following line of code to my using block:

Using Aspose.Word;


And then I get that error message that I mentioned. One thing to note is that when I was adding a different user control to my toolbox, Visual Web Developer complained that Aspose.word.dll was missing something. Any ideas?

Thanks!

Ok, I just realized that I had installed an earlier version of Aspose.word by mistake (without really reading version # or date, I assumed the latest release was at the top of the list on the download page)… so I tried downloading the latest release and now it’s working Smile

Thanks