Free Support Forum - aspose.com

Version of .Net required for Aspose.odf

I am unable to install aspose.pdf on .net frameword v1.1. Is there a specific version of .net required for this?

Thanks

Raji


This message was posted using Aspose.Live 2 Forum

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for considering Aspose.

I have tested the scenario while installing Aspose.Pdf for .NET 4.2.0 over Windows XP SP2 with .NET Framework 1.1 and I am unable to notice any problem. The product is being installed without any problem. Can you please make sure that the account that you are using for installation has sufficient rights to perform the installation or the destination folder is not right protected.

In case you still face any issue, please try using the attached .dll of Aspose.Pdf for .NET for .NET Framework 1.1. In case of any further query, please feel free to contact.

We apologize for your inconvenience.

I downloaded the files you had sent and tried registering and still the same problem.

Attached is the screenshot of the output screen.

Please advise what could be the problem

Thanks

Raji

Sorry couldnt attach the file. But it displays the following error :-

Regasm Error: Failed to load \aspose.pdf.dll because it is not a valid .net assembly.

When I install .net verison 2.0 and install aspose.pdf.dll for vers2 I am able to successfully register the assembly.

In the field offices we plan to use this, I cannot be sure of the versions of .net they will have. So I have to ensure it works in all versions.

Thanks

Raji

Hello Raji,

I am afraid the picture is not available with the previous post. Can you please take a look over this matter.

We apologize for your inconvenience.

I am unable to attached the picture since the control to upload files doesnt appear on this screen.

Hence I had sent the error message that was displayed which I am sending here agian

RegAsm Error: Failed to load ....aspose.pdf.dll because it is not a valid .Net assembly.

Thanks

Raji

Hello Raji,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tested the scenario using following command with Aspose.Pdf for .NET v.1.1 and I am unable to notice any problem. The library is being registered without any issue. I have also attached the screenshot of the command prompt console, please take a look.

C:\Program Files\Microsoft Visual Studio 8\VC>regasm "C:\Program Files\Aspose\As
pose.Pdf for .NET\Bin\net1.1\Aspose.Pdf+for+.NET+_net1.1\net1.1\Aspose.Pdf.dll"
/codebase

I have also tested the scenario while registering the .dll that I have shared in my earlier post.

Thanks Nayyer. I have also been trying to install the same and I couldnt install aspose.pdf.dll for .net 1.1 when .net 1.1 was installed on my machine. I was sucessful in installing aspose.pdf.dll for any .net version if my machine had .net framework 2.0. From your screenshot also I see that you have .net 2.0.

So I think I will have to put a check in my application for .net 2.0 or above.

Thanks

Raji

Hello Raji,

Sorry for my previous reply.

I had an impression that you are trying to install the Aspose.Pdf.dll which comes in 1.1 folder in Aspose.Pdf for .NET installation directory. Please ignore my previous post as I will test the scenario with .NET Framework 1.1 and will update you with my findings accordingly. Please spare us little more time and we will get back to you, shortly.

We apologize for your inconvenience.

Hello Raji,

I have again tested the scenario with .NET Framework 1.1 and I am able to notice the problem. We will look into the details of this issue and will keep you updated on the status of correction. Please spare us little time and we will get back to you, shortly.

We apologize for your inconvenience.