We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Viewing aspose javadoc in eclipse

Hi,

How can I view the aspose javadoc in eclipse?

I tried to connect the aspose jar (in the list of maven dependencies of the project) to the javadoc location in the aspose site (http://www.aspose.com/documentation/java-components/aspose.words-for-java/apijavahome.html). The validate button indicates that the location is likely valid.

However, when hovering over an aspose method I get the following message: This element has no attached source and the Javadoc could not be found in the attached Javadoc.

Thanks, Neva

Hi Neva,

Thanks for your inquiry.

The address you have setup is correct. Are all of the members producing that error or just some? If only some, which ones?

We are aware that there are a few members that for some reason don't show up in Eclipse, they do show up properly in other Java IDE however. I will look into the cause of this sometime in the future.

Thanks,

Hi,
OK, I see what you mean. Some of the elements do indeed show javadoc.
However the major ones - Document, DocumentBuilder, FieldMergingArgs, and perhaps others - do not show the documentation.
Note that hovering over methods on some classes shows the following message: “An exception occurred while getting the Javadoc. See log for details”. (For example - FieldMergingArgs methods cause this message)
Hovering over others return the message I indicated before.
Thanks, Neva

Hi Neva,

Thanks for this additional information.

Strangely enough in my test before and in the past I tried both Document and FieldMergingArgs and they show up fine on my end. Other members like the Save method of Document do not.

This is very strange behaviour, I have linked your request to the appropriate issue. I will keep you informed of any developments. In the mean time I'm afraid if you are unable to use another IDE then you will need to manually look up some members. I apologise for any inconvenience.

Thanks,

Hi Adam,

I have the same problems - using eclipse and unable to see most of the javadoc. To solve this, I also manually connected the jar file to the given URL - but still I have problems to see everything (for example most of the Document method docs etc).
Also, I zipped the javadoc provided within the aspose.words.zip and tried connecting this to the aspose.words.jar - Eclipse then gives me an error saying that the file structure of the javadoc is invalid.

Any help on this would be much appreciated, since I cannot switch to another IDE, and looking up every method manually in the browser is taking up very much time. Thank you very much!

Hi Christina,

Thanks for your request. This problem is already logged in our defect database. We will let you know once it is fixed. I apologize for inconvenience.

Best regards,