We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Visual Studio 2010 Changes Reference Path

We are using Visual Studio 2010 with a 3.5 framework and Aspose.Words 9.5.

The solution has just been migrated from VS 2008 to VS 2010, still maitaining the 3.5 framework.

In the process of doing so, the reference paths for Aspose.Word changed from pointing at the 2.0 dll to the 1.1 dll. I am attempting to reference the 2.0 dll, but upon closing the reference window and checking the properties again, the path still points to the 1.1 dll, with the 1.1 Runtime Version.

I can reference the 3.5 dll, and that maintains the path correctly and uses the 2.0 Runtime Version, but the 3.5 dll does not have the ability to save to a browser window, so I can't use it.

The solution still compiles and everything is working correctly. Is this going to be a problem for me?

Hi

Thanks for your request. Have you tried to browse the correct Aspose.Words.dll and add reference to it? i.e. add reference to Aspose.Words.dll not from .NET tab, but from Browse tab in “Add reference” dialog.

Best regards,

Yes, that is how I have been trying to do it - by browsing to it, but it still shows that it points to the 1.1 dll.

Hi

Thank you for additional information. This is quite odd. I cannot reproduce this on my side. Are you sure you are referencing the correct dll? Maybe there is simply incorrect dll in place from where you are referencing it.

Best regards,

The dlls are in the correct places.

In VS 2008,
if I connect to the 1.1 dll, it displays it is referencing the 1.1 dll with 1.1.xxx Runtime Version
if I connect to the 2.0 dll, it displays it is referencing the 2.0 dll with 2.0.xxx Runtime Version
if I connect to the 3.5 dll, it displays it is referencing the 3.5 dll with 2.0.xxx Runtime Version

In a previous post, you asked if I was referencing the dll via the .Net Framework tab, or browsing to it. I can only browse to it. It does not display in the .Net Framework tab at all.

Hi

Thank you for additional information. Unfortunately, I still do not have any idea why this might occur. I checked on my side once again and reference is correct. Please see the attached screenshot.

Have you tried to download the latest version of Aspose.Words and use it?

Best regards,