We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Visual Studio 2012 - Aspose.Slides Fails to load assembly

Hi,


Running Visual Studio Professional 2012 (11.0.61030.00 Update 4)
.Net 4.5.51641

I get the following error when trying to Preview Reports in Visual Studio. The assembly runs “fine” on the server located on the same machine.
(I say “fine” because Graphs export as blurry, i am yet to find a solution to this. Exports fine to Excel etc, but PowerPoint exports are blurry… But i guess i should post that in a separate ticket.)

"Could not load file or assembly ‘Aspose.Slides.ReportingServices, Version=5.0.0.0, Culture=neutral, PublicKeyToken=716fcc533a201e56’ or one of its dependencies. Failed to grant minimum permission requests. (Exception from HRESULT: 0x80131417) Required Permissions cannot be acquired."

Installation notes:
C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\PrivateAssemblies
1) Aspose.Slides.ReportingServices.dll ( File version 5.0.0.0 )
With the same permissions as other files in the same directory.

2) RSPreviewPolicy.config added:
<IMembershipCondition class=“StrongNameMembershipCondition” version=“1”
PublicKeyBlob=“00240000048000009400000006020000002400005253413100040000010001005542e99cecd28842dad186257b2c7b6ae9b5947e51e0b17b4ac6d8cecd3e01c4d20658c5e4ea1b9a6c8f854b2d796c4fde740dac65e834167758cff283eed1be5c9a812022b015a902e0b97d4e95569eb8c0971834744e633d9cb4c4a6d8eda03c12f486e13a1a0cb1aa101ad94943236384cbbf5c679944b994de9546e493bf”/>

3) RSPeroprtDesigner.config added:

4) PrieviewProcessingService.exe.config “Optionally tested” to add

Hi,


Thanks for inquiring Aspose.Slides.

I have observed the requirement shared by you and suggest you to please visit these guidelines mentioned in manual installation procedure on your end. Please verify your settings as per setting given in link. If there is still an issue please share with us and I will try my best to help you further in this regard.

Many Thanks,

Perhaps i was un-clear.


It works fine on the server.
It is in the debug/preview enviroment (Visual Studio 2012) that i cannot get it to load the assembly.

My best guess would be that the information given Here is no longer valid (publickey perhaps, since there has been a major release v.5.).

I have followed the instructions there to the point but still get the same permission exception.

Best regards,
Viggo

Hi Viggo,

I have observed the feedback shared by you. Can you please make sure that you have user rights to access the Aspose.Slides dll. Also, you need to use FullTrust permission in order to use Aspose.Slides on your end. Please make sure that the user with which you are trying to use Aspose.Slides for Reporting Services for Visual Studio 2012 has access available to load the assembly. Please share the complete stack trace and complete environment details with us if the issue still exist on your end.

Many Thanks,