Free Support Forum - aspose.com

VSD to PDF conversion loses hyperlinks

Hi,



When converting any VSD files to PDF using Aspose.Diagram 3.7.0, all hyperlinks seem to be lost. See the attached VSD file and the converted PDF file as a sample. The VSD has a hyperlink in both arrow shapes as well as in the text box, but the PDF doesn’t seem to have any.



I noticed other reports of hyperlink-related problems with Aspose.Diagram, relating to VSDX format. They seemed to indicate that part of the hyperlink is preserved, but in my case with the VSD file I don’t seem to get any hyperlinks.



Please ensure that hyperlinks would be preserved in both VSD to PDF and VSDX to PDF conversion, and make sure that the full hyperlink is included, i.e., including also any querystring parameters.



Antti

Hi Antti,


Thank you for reporting us. I managed to replicate the problem of missing hyperlinks on my side. I’ve logged this problem for VSD and VSDX formats separately under ticket id DIAGRAMNET-50064 and DIAGRAMNET-50065 in our issue tracking system. Your request has also been linked to these issues and you will be notified as soon as it’s fixed. We’re sorry for your inconvenience.

Thanks, Imran. This issue is critical in one of our current customer implementations. We’d like to understand if this will eventually be fixed, and if it is likely that the fix will be available before end of May.

I know that it’s difficult or impossible to give any hard guarantees, but I’m hopeful you could provide me with your best understanding regarding the schedule of this fix. This will allow us to either wait for the fix, or look for another solution for this particular purpose if the fix is likely to be in too distant future for us.

Antti

Hi Antti,


Thank you for asking about the resolution. I have discussed your issues with our development team. I would like to update you that our development team has plans to fix these issues before the end of May, 2014. It’s depend upon if everything goes by plan. We shall let you know once these issues are resolved.

Thanks, Imran. I really appreciate the info.

Antti

The issues you have found earlier (filed as DIAGRAMNET-50064) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as DIAGRAMNET-50065) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as ) have been fixed in this Aspose.Words for JasperReports 18.3 update.