Free Support Forum -

WBS is automatically renumbered for MPP files (C# NET)

Currently using Aspose.Tasks .Net Version 19.4 but this same problem happened in 17.1 as well.

I am trying to read the WBS from an MPP file as it appears in Project. I do not want to renumber the WBS.

Below is a simple example that reads the WBS. If I run this with a MPP file that was created using Project 2010 it works as expected. But if I run it with a MPP file that was created using Project 2016 the WBS is incorrectly renumbered. The sample files are identical except that the Project 2016 file was opened in Project 2010 and then resaved with a different name.

Example code:
// Setup the szFilename variable to point to the mpp file.
prj2 = new Project(szFilename);

List tasks = (List)prj2.RootTask.SelectAllChildTasks();
for (int x = 0; x < tasks.Count; x++)
string szWBS = tasks[x].Get(Tsk.WBS);
// Print szWBS to output of your choice

Example files are (99.1 KB)



We checked your files and found that there is no information (inside MPP) about WBS codes in the file WBSBrokenMSP2016. Because of that Aspose.Tasks regenerate WBS codes.

BTW, we tried to resave your 2010 file in MS Project 2016 and then check it. And all WBS code are there. Please check the gif file attached.

Please update MS Project 2018 to the latest version and resave 2010 MPP file again, it should help you.wbs.gif (2.1 MB)

Thank you for the reply. However I believe there is a WBS in the WBSBrokenMSP2016.mpp file. When I open the file in Project 2016 it clearly shows a WBS. Here is a screenshot of the file in Project 2016:
BrokenWBS_ShowsInProject.jpg (292.6 KB)

As you can see the WBS is defined for each task. If I open this same file, WBSBrokenMSP2016.mpp, in Project 2010, it shows the same WBS as Project 2016. But when I read it using Apsose.Tasks the WBS does not match Project 2016 or Project 2010.

Thank you for clarification, we will investigate it deeply.

I was wondering if there was any update on this issue? Either a fix or a work around?


I regret to inform that issue is pending for detail investigation. I also like to inform as per our company policy, the first priority for investigation is given to the Paid Support i.e. Enterprise and Priority Support on first come first serve basis. After that the issues from normal support forum are scheduled for investigation on first come first serve basis. I request for your patience. We will share good news with you soon regarding your issue.

Is there any update on this? We recently paid a lot of money to upgrade to the latest version of Aspose only to find that this problem still exists. Based on your last response it appears that bugs in the software will not be fixed unless we pay additional money to have you fix them. I’m hoping this is not true.

@dmikofalvy Hello!
The issue has been fixed in Aspose.Tasks for .NET 19.5 (Release Notes) which has been released in the end of May. BTW, please try to use the latest Aspose.Tasks for .NET 19.7.

Thank you for the response. I will upgrade to the latest version.


You are very welcome.