We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

What library and save options does the online "demo" converter website use?

I’m using Aspose.PDF’s c# documentation to convert PDF to docx, and the documentation recommends using the demo website to “test the quality of the conversion library.”

However when I run Aspose.PDF myself, the conversion results are different from the demo website. I see issues similar to this and this.

What Aspose library is the demo website using, and what SaveOptions does it have set? I am happy with the demo website’s output, but my deployment will be on premise, so using the cloud API isn’t an option.

Thanks in advance!

@draftwise

Aspose demo website, (PDF to DOCX) conversion uses Aspose.PDF APIs at backend. Please note that Aspose.PDF requires true types fonts while PDF to DOCX conversion. So, all fonts used in the document should be installed on the system where PDF to DOCX conversion is performed.

Both issues are related to fonts.

Please make sure that all fonts of document are installed on your system. If you still face problem, please ZIP and attach your input PDF along with problematic and expected output DOCX files here for testing. We will investigate the issue and provide you more information on it.

Hi @tahir.manzoor, thanks for the quick response. I am able to view the PDF in chrome, acrobat, and MacOS preview without any issue, which suggests to me the system I’m using has necessary fonts installed. If this is an incorrect assumption, can you please direct me towards instructions on how to locate what fonts I’m missing or commands to run to install them?

I have also run my java service within a docker container with the microsoft fonts installed using this command.
apt-get install ttf-mscorefonts-installer

Lastly, I’ve also set Document#setAbsentFontTryToSubstitute to false, which I understand should fail the conversion if the system is missing fonts, and it doesn’t fail or show warnings.

I found this post with a list of fonts. I’ll give it a try and report.

@draftwise

Please install the required fonts to avoid the shared issue. If you still face problem, please share the requested documents for testing.

I installed the required fonts but still face this issue. I also added a warning callback which logs any warnings, and there were no warnings during the conversion process.

Here’s my document:
NVCA-2020-IRA 13.pdf (636.6 KB)

@tahir.manzoor I’m running my code in a debian-based docker image, and I read in a wordpress blog that Apose-PDF will use the standard debian font directory to find fonts (/usr/share/fonts). I have all the MS fonts installed. However, I added logging to print available fonts from SystemFontSource, and there were no fonts found. I believe this is a bug: Aspose isn’t detecting installed fonts in /usr/share/fonts on a openjdk:17.0.1-buster container.

I tried working around this by calling FontRepository.addLocalFontPath with each directory in /usr/share/fonts/opentype and /usr/share/fonts/truetype, and now when I call SystemFontSource#getFontDefinitions, it prints out a lot of fonts. However, its still not converting correctly. Here’s how it looks:

Screen Shot 2021-12-01 at 7.56.12 PM.png (51.8 KB)

If I convert the font to Arial after opening the file in Word, then it looks fine.

@draftwise

In case you are using old version of Aspose.PDF for .NET, we suggest you please use the latest version of Aspose.PDF for .NET 21.11. After installing the fonts, please restart the system and then perform the PDF to DOCX conversion.

If you still face problem, please share the simplified code example that you are using and attach your problematic output DOCX. We will investigate this issue further and provide you more information on it.

1 Like