We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Which aspose.slides-2.8.0 jar we should use with jdk 1.5

Hi,


We have jdk 1.5 environment on server.
There are two jars of aspose.slides-2.8.0 are available. which one we should use.
We are getting error with both of the jar.

With aspose.slides-2.8.0-jdk14 we are getting following error.

<o:p> </o:p>SRVE0068E: Uncaught exception thrown in one of the service methods of the servlet: /jsp/html/thumbnail4.jsp. Exception thrown : javax.servlet.ServletException: Error while defining class: com.aspose.slides.obfuscated.boc

<o:p></o:p>

This error indicates that the class: net.sf.retrotranslator.runtime.java.lang.Enum_<o:p></o:p>

could not be located while defining the class: com.aspose.slides.obfuscated.boc<o:p></o:p>

This is often caused by having the class at a higher point in the classloader hierarchy<o:p></o:p>

Dumping the current context classloader hierarchy:<o:p></o:p>

==> indicates defining classloader<o:p></o:p>


<o:p> </o:p>java.lang.NoClassDefFoundError: net.sf.retrotranslator.runtime.java.lang.Enum_


With aspose.slides-2.8.0 also we are getting error


Error 404: SRVE0203E: Servlet [/jsp/html/thumbnail64.jsp]: org.apache.jsp._thumbnail64 was found, but is missing another required class. SRVE0206E: This error typically implies that the servlet was originally compiled with classes which cannot be located by the server. SRVE0187E: Check your classpath to ensure that all classes required by the servlet are present.SRVE0210I: This problem can be debugged by recompiling the servlet using only the classes in the application’s runtime classpath SRVE0234I: Application classpath=[C:\IBM\WebSphere\wp_profile\PortalServer\config;C:\IBM\WebSphere\PortalServer\shared\app;C:\IBM\WebSphere\PortalServer\shared\app\aspose-cells-7.1.0.4.jar;C:\IBM\WebSphere\PortalServer\shared\app\aspose-metafiles-1.7.1.jar;C:\IBM\WebSphere\PortalServer\shared\app\aspose-pdf-kit-4.0.1.jar;C:\IBM\WebSphere\PortalServer\shared\app\aspose.pdf-3.0.1.jdk15.jar;C:\IBM\WebSphere\PortalServer\shared\app\aspose.slides-2.8.0.jar;C:\IBM\WebSphere\PortalServer\shared\app\Aspose.Words.jdk15.jar;C:\IBM\WebSphere\PortalServer\shared\app\bcprov-jdk15-146.jar;C:\IBM\WebSphere\PortalServer\shared\app\dom4j-



Hi Avinash,


Thanks for considering Aspose.Slides.


You are right that Aspose.Slides for Java 2.8.0 download package has no jar file compatible with JDK1.5.

I have already floated a request for investigation to developer with ID SLIDESJAVA-33144. Our development team will look into the possibility of sharing requested jar if there exists one. This thread has been associated with this investigation request, so that you can be automatically notified as soon as this issue is resolved.


Sorry for your inconvenience

Hi, I tried with the new aspose.slides.2.9.0.jar, I still get the same error.

We are using JDK1.5 on our server. Any updates on this issue further?

Regards

Sundhar

Hi Sundhar,


I regret to share that the issue has not yet been resolved. I have requested the concerned developer to share the updated response over the status of the issue and will share that with you as soon as possible.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-33144) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(4)

Hi Thanks for the fix., Now it works fine.