We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

WinForm application not recognizing 1D barcodes

We recently purchased the ASPOSE.BarCode library. I wrote a .Net sample program to recognize bar codes. In the evaluation mode, it worked fine; when we purchased it and installed the production version, it stopped working.



The evaluation version of 6.X something.



The version that is failing is 7.5.0.0. We also tried 7.4.x.x.



The code we created recognizes 2D bar codes fine. It does not recognize any of the 1D bar code samples we created. We even tried some of the sample 1D barcodes files in the documentation for the BarCode library. The did not work either.



The WinForm app is using .Net Framework 4.5.2. We have tried .Net Framework 4.0 and it fails also.



The sample code allows the user to browse to a local file. That file is then loaded into a BarCode Reader object. The “Read” method that attempts to recognize the file returns false.



Below is a code snippet. I have attached a sample barcode file that fails to recognize.



Aspose.BarCodeRecognition.BarCodeReader oReader;

oReader = new Aspose.BarCodeRecognition.BarCodeReader(msImagePath, Aspose.BarCodeRecognition.BarCodeReadType.Code39Standard);

bool bRecognized = false;

while(oReader.Read())

{

// get symbology type

// get code text

moConsole.WriteLine("CodeText: " + oReader.GetCodeText());

moConsole.WriteLine("Symbology Type: " + oReader.GetReadType().ToString());

bRecognized = true;

}

oReader.Close();

if (!bRecognized) moConsole.WriteLine(“Barcode was not recognized.”);



We have tried initializing the “BarCodeReader” instance with and without the BarCodeReadType specified. It made no difference.



Any suggestions?

Hi Dan,

Thank you for your inquiry.

We have evaluated your scenario and were able to replicate the said issue. The issue has been logged into our issue tracking system with ID BARCODENET-34329. Our product team will further look into it. We will update you accordingly.

As an additional test, I tried the “Aspose.BarCode.Toolkit” provided in the “Toolkit” folder. It too does not recognize any 1D barcodes; it returns “No BarCode found.” I tried this same utility on three other machines, Windows Vista Premium, Windows 7 Professional and Windows 8.1 RT. All three returned “No BarCode found.” for any 1D barcodes. If I scanned a 2D barcode, it recognized it.

Seems more and more like I got a bad build.

I really, really, really need this fixed. We purchased this software and have not been able to use it for what we wanted it for.

Please give me an update.

Thanks.

Hi Dan,

Thank you for your patience.

Please note that the issue has been fixed and will be included in the very next release i.e. Aspose.BarCode for .NET 7.6.0.

Do you have an estimate when that release will be made available?

Chat support says next release not available until January of 2016! Wow.

Is there any sort of work around I could do before then? Does a previous version work? I tried some of the 6.X versions and they had the same problem.

If it is indeed the case, I may want a refund. That is pretty ridiculous to me.

Hi Dan,

Please note that our product team is working on the upcoming release i.e. Aspose.BarCode for .NET 7.6.0. We will try to release this version within time of one week. It can be delayed to two weeks maximum in case of any issue.

We thank you for your cooperation.

The issues you have found earlier (filed as BARCODENET-34329) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.