Free Support Forum - aspose.com

Word and Pdf Differences

Hello,

When I save a document to both a Word doc and a Pdf I am seeing some differences in the resulting outputs.

  1. The areas with the blue background are difference size; see Page 1 the first text ‘Purpose’, Page 2 the text ‘Screen Flow’, etc…
  2. The Pdf output, when viewed at exactly the same zoom as the Word doc, seems much darker… almost bolded and there seems to be no anti-aliasing of text
  3. There is a single pixel border around screen images under the ‘Procedure’ area, starting Page 3, that do not show up in the Pdf
  4. On Pages 5 and 6, the Pdf is splitting the table header from the next table row while the Word correctly moves the entire table to be on the next page.
Attached are the two files I am referencing.

Thanks!

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request.

1. I cannot reproduce this issue on my side. Blue areas is shown correctly in the PDF generated on my side. I use the latest version of Aspose.Words (6.2.0) for testing.

2. I managed to reproduce the problem and created new issue #8125 in our defect database.

3. I create new issue #8126 in our defect database regarding this problem.

4. I logged this problem to our defect database as issue #8127.

I will notify you as soon as these issues are resolved.

Best regards.

Alexey,

Thanks for looking into this. For #1 if you look at the blue space above and below the text in the Pdf and compare it to the blue space above and below the text in the Word output you can see that they are slightly different, with the Pdf being more compact than the Word output. I am using the latest version of 6.2.0.

Also, is there any sort of time frame I can expect for these fixes? We hit code complete in a few weeks and if they’re not fixed by then I’ll need to revert back to using Aspose.Pdf for our publishing process.

Thanks!

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I see the differences in your PDF and Word document, however if I convert your document to PDF on my side blue areas look fine. I created screenshot for you.

Currently, I cannot provide you any reliable estimate regarding these issues. Please expect a reply before next hotfix (within a month).

Best regards.

Ahhh ok, I must be using a different version of Adobe Reader. I’m on 8.0.3.

Thanks for the quick reply and I will look forward to your update.

Thanks!

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I do not think this problem is related to PDF reader you are using. The PDF document on the screenshot was generated on my side using Aspose.Words 6.2.0. The PDF you attached looks a bit different – size of blue areas is incorrect. That is why I supposed that you are using some old version of Aspose.Words for testing.

Best regards.

The issues you have found earlier (filed as 8126) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as 8127) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as 8125) have been fixed in this .NET update and in this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.