Word and PPT to PDF: Some characters are missing in rendering (.NET)

Hi there,
I’m using the following snippets to save doc and ppt to pdf. With my samples, some character can’t show correctly, can you investigate it?
sample.zip (127.4 KB)

Aspose.Words.Document document = new Aspose.Words.Document(inputFile);
document.Save(outputFile, Aspose.Words.SaveFormat.Pdf);
Aspose.Slides.Presentation presentation = new Aspose.Slides.Presentation(inputFile);
presentation.Save(outputFile, Aspose.Slides.Export.SaveFormat.Pdf);


We have tested the scenario and have managed to reproduce the same issue at our side. For the sake of correction, we have logged this problem in our issue tracking system as WORDSNET-19091. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

We are investigating this issue and will get back to you soon.


I have observed the output w.r.t Aspose.Slides perspective for PowerPoint presentation. I suggest you to please ensure that fonts used in presentation are available on machine where you are performing rendering. Can you please ensure this on your end.

My slide is using font Arial and Calbiri, these are default font in Windows os, but problem occured with font arial, not with calbiri.


Yes, I understand that as Georgian Arial Font is not getting rendered on your end. Can you please try installing this font on your end and then try using the application.

I’ve installed your recommended font, but the issue still occurs.

@tahir.manzoor @mudassir.fayyaz
After tried FontSetting.FallbackSetting in Aspose Words, I can render these character correctly. So is there the same FontSetting.FallbackSetting in Aspose Slides?


I have tried using Aspose.Slides for .NET 19.7 in Windows 7 SP1 environment. The PDF generated has no issue and I have shared that for your kind reference too. Is it possible, if you may please share the sample solution project along with environment details on your end.

test_ppt.ppt.pdf (60.0 KB)

I tried to using Aspose Slides .NET 19.7 and Windows 10. With the previous code in my first comment, the characters can’t render. Then I tried DefaultRegularFont, DefaultAsianFont in load option, Aspose can render the language I used in sample, but can’t render other language such as: Thai, Lao,…
I can render these language correctly with font fallback setting of Aspose Words, so I wonder how we can using font fallback with Aspose Slides? Or can you share your solution?


As I shared with you earlier that I have used a very basic conversion using default options on my end and it had no issue. I have already shared my environment details with you and therefore, I have requested you to please share your solution project with us that is reproducing issue on your end along with .NET Framework information.

Secondly, there is no such option as you have shared in case of Aspose.Words available in Aspose.Slides. The API works without any fall back settings and I have already shared my output PDF file with you for your kind reference as well.

I used Aspose Slides 19.7 for .NET, Windows 10 x64 ver 1903, I also installed font “Arial GEO” as your recommend. And I tried with following code solution and result is the same with my origin issue. I also read this Aspoe.Slide Font substitution is not rendering non-latin character based languages correctly (Java) - #13 by sbd in forum but I can’t find how to fix it. Can you let me know the way to render these language correctly?
Thanks for your patience.
my sample solution


Thank you for sharing the elaboration. An issue with ID SLIDESNET-41356 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.


We have tried to reproduce the issue on our end and have not been able to reproduce it. Can you please share detailed description for run environment. Especially about all installed fonts on machine where you are performing this.

Hi @mudassir.fayyaz,
image.png (84.6 KB)

This is all fonts on my end. I tried to save the sample PPT file to PDF on Windows 10 x64, .NET 4.0, Aspose Slides 19.7. I also updated Aspose Slides 19.9 but the issue isn’t resolved.


Thank you for sharing requested information.

The issues you have found earlier (filed as WORDSNET-19091) have been fixed in this Aspose.Words for .NET 19.10 update and this Aspose.Words for Java 19.10 update.


Can you please try using following sample code on your end using Aspose.Slides for .NET 20.1.

using (Presentation pres = new Presentation(pptFileName))
pres.FontsManager.FontFallBackRulesCollection.Add(new FontFallBackRule(0x10A0,0x10FF,"Sylfaen"));
pres.FontsManager.FontFallBackRulesCollection.Add(new FontFallBackRule(0x4E00, 0x9FD5, "Microsoft JhengHei"));
pres.Save(pdfOutFileName, SaveFormat.Pdf);

Hi @mudassir.fayyaz,
We can produce expected result with your code snippet and new version of Aspose Slides.
Thanks for your support.