Word Crashes when opening mail merge document!


#1

Hi Roman

I have a system that creates two fairly large mailmerge documents. One around 500kb and the other around 250kb.

I had them working absolutely fine, and for reason now, when opening the document it crashes word completely. I have tried it on several machines and am getting the same problem.

I did think it was due to NULL values being returned for some of the fields, but I know in the past it has still worked, just leaving those fields blank, which is what I want.

Im thinking it may be the formatting in my template document, it is a large document with quite a few section breaks to use different page setups.

I will email you one of the documents now, as I expect you may need them.

Cheers,
Joe


#2

Hi Roman

I have just being playing around with my templates and it is being very odd. I delete all the pages apart from the first 3 and start adding a page at a time.

I now have 10 pages and the mail merge executed fine and the word file opened. I then deleted it and tried once again the I got a different error that before. I tried re-creating once again and still get the error.

It just doesn’t make any sense… Tongue Tied

The error says:

The exception Illegal Instruction
An attempt was made to execute an illegal instruction.
(0xc000001d) occured in the application at location 0x006d0095.

This is happened when I am trying to run the ‘Physio’ template I emailed to you.

Cheers,
Joe


#3

Hello again

I’ve been playing with the ‘PhysioFile.DOC’ template. I have found that page 6 is crashing it and I cannot find out why. If I keep the first 5 pages it crashes.

I did have it running with 6 pages once but as soon as I clicked on the image on the top of the page it crashed.

After that I tried changing the template again so the image wasnt even on the page. It then crashed again while loading.

I just can’t work this out as it was all working fine yesterday, something really weird is going on.

I also tried to ‘repair’ my office install and this also didn’t make any difference.

Do you have any suggestions? I have to demo this app on Thursday, and I’ve spent the whole day trying to fix this, and there is more to do for the demo Sad

Cheers,
Joe


#4

Hi Joe, I’m looking at the files and will report back asap.


#5

I cannot find any problems with the files produced by Aspose.Word from your templates.

I use WordXP (Word2002) to open them, click and go into properties of images, paragraphs etc. No crashes.

Please make sure you are using latest Aspose.Word 1.7 and let me know what Word version you are using.


#6

Thats odd… I sent the file to a few people here and we all couldnt open it. I am using Word 2000 as that is what we have here.

Another odd thing is that I started rebuilding the template yesterday and it was working fine. I had removed the images and re-imported the jpg’s and it all seemed to be working. I have just come into work, opened the file that worked yesterday, and it crashed Tongue Tied

I have no idea what is going on


#7

Ok, I’ll try it on Word 2000 too. Did you check you use the latest Aspose.Word version?


#8

Yes, I am using the lastest Aspose.Word.

We just installed Word XP on a test machine and it opened the file fine. At least thats one solution, but all other machines here are using Word 2000.

Im just re-building the template again and at the moment I have it working on Word 2000 but I am expecting it to crash at any time Smile

Cheers,
Joe


#9

It did it again Tongue Tied

I had the template working with all pages but one. I then ran the mailmerge for a different record in the database and it crashed again. I then tried running it for the first record which was working fine, and now it just keeps crashing. Not sure what to do. Think for now I will install WordXP so I can finish working on it.

Joe


#10

Hi Roman

I’ve just installed Word XP on my own machine and everything works great, no problems what do ever. This makes me think it must the something Aspose is doing, as the templates before the mail merge open fine in 2000, but after the mail merge don’t.

Cheers,
Joe


#11

Anything that causes MS Word to crash is likely to be Aspose.Word’s fault. We are working half-blinded here because .doc format is not fully documented and we sometimes just not sure what to expect form the .doc files.

Don’t worry I will certainly fix the issue you have on Word 2000. It’s nice to hear that you have it working on WordXP and hopefully it will be enough for your demo to go smooth.

I appreciate you trying to figure out what is so special about your template, but I’d recommend you don’t spend too much time on it because I’m in much better position to solve this with all source code.


#12

Hi romank
regarding the issue of “Word Crashes when opening mail merge document!” Have you been able to resolve the problem. Our clients are all running Windows 98 With Office 97/2k. The demo went OK as we were able to present it on a machine with Office XP installed but we need to go live with the application very soon and were hoping that you had managed to resolve the issue.

Regards
Gavin


#13

Hi romank
I have updated my app with the latest version of Aspose Word and it is still not working!

Thanks
Gavin


#14

Hi, we are still working on this issue, hope to get positive results by Monday.


#15

Hi,

The problem was caused by two tables (I managed to isolate them by removing different pages from the document and then different elements from the pages that caused the crash).

One table was on page 6 (REASON FOR REFERRAL ) and another on page 11 (

For completion on discharge: )

I’ve deleted those tables and recreated them manually in the document and that fixed the problem.

I’ve also made some improvements to the way Aspose.Word 1.8.1 writes the tables, but that did not solve the problem. So the real reason for the crash is still unknown, but if you recreate the tables as I described above, it will help.


#16

Do you still have documents that crash any MS Word versions? All of your documents that I produce with Aspose.Words at the moment (v 3.6) open in MS Word versions fine.