Free Support Forum - aspose.com

Word to PDF - Table borders not rendered correctly

Hi,

We have upgraded from Words 4.4.2.0/Pdf 3.6.1.0 to Words 5.0.0.0/Pdf 3.6.2.0 and have noticed that table borders are not correctly converted to PDF anymore (see examples in attachment).

We have also tried Pdf 3.6.2.0 in combination with Words 4.4.2.0 but then the layout gets totally screwed up.

We started using Aspose components about a year ago and are generally happy about their design and capabilities, but it is quite disappointing that every time we install an upgrade, some things stop working so we cannot release it to our customers, which are waiting for other fixes and improvements in the new version. We would like to see a quick solution for this problem and more thoroughly tested future releases.

Best regards.

Dear Hemmis,

Thanks for considering Aspose.
I have test your case with Words 5.0.0 and Pdf 3.6.2.0. But I am not able to reproducet the error. Would you please make sure the references are correctly set and try it again? Thaks.

Best regards.

Please find the project in attachment demonstrating the issue (very thick table borders in PDF).

Hi,

I think this bug is caused by a bug of Aspose.Words. Please try hotfix 5.0.1.

Nope, problem still exists in Aspose.Words 5.0.1

I have reproduced this error by setting the language to Spanish. It seems the bug still has not been fixed by Aspose.Words. I found the following lines in the XML:






I will move this post to Aspose.Words forum and they will process it.

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your inquiry.

I’m sorry. Our fix didn’t get into the recent build. We are taking measures to resolve this and will give you additional info.

As a workaround you can temporarily set culture info for the current thread to “en-US” before exporting and revert it back after it. Culture info is changed by this line of code:

Thread.CurrentThread.CurrentCulture = new CultureInfo("en-US");

Regards,

OK, that did the trick for now. Thanks for the quick solution.