Free Support Forum - aspose.com

Words .NET MS SQL CLR Problem

I have registered Aspose.Words.dll as an assembly on my SQL 2008 Server like so:


CREATE ASSEMBLY [Aspose.Words]
FROM N’C:\Program Files\Aspose\Aspose.Words.dll’
WITH PERMISSION_SET = UNSAFE
GO

When trying to instantiate a license object like so:

Aspose.Words.License license = new Aspose.Words.License();

I get the following exception:

"That assembly does not allow partially trusted callers."

I have tried this with the .NET 2.0, 3.5 Client Profile & 3.5 Client Profile Authenticode Signed dlls. Since I am registering the assembly as UNSAFE as seen above, I am perplexed at the exception.

Any help is greatly appreciated.

I should also mention that this problem occurs with v14.7.0.0 but does not seem to occur with v10.1.0.0. I am trying to get other versions to test to try to determine when the problem crept in.

Hi Mike,

Thanks for your inquiry. I have tried to create assembly in SQL Server 2008 R2 and faced the following exception.

CREATE ASSEMBLY for assembly ‘Aspose.Words’ failed because assembly ‘Aspose.Words’ is not authorized for PERMISSION_SET = UNSAFE.

Could you please elaborate some detail about your requirement what exact you want to achieve by using Aspose.Words? We will then provide you more information about your query.

I need to call the Words library from a scheduled stored procedure which runs every few minutes. Words converts .doc, .docx and .txt documents to PDF during this process.


Not sure why you got the error you got when registering the assembly. I was able to register it but not call it. Something has changed between v10.1.0.0 and v14.7.0.0 which appears to make it incompatible with SQL CLR.

Unfortunately, v10.1.0.0 seems to have a problem converting .txt files so I can’t use that version either. I am also concerned that going forward, Words may be incompatible with SQL CLR.

I appreciate you help trying to track this down.

Update: v13.9.0.0 gives the same error: "That assembly does not allow partially trusted callers."


Is there somewhere I can download builds between v10.1.0.0 and v13.9.0.0 so I can determine exactly when this was broken?

Thanks in advance.

Hi Mike,

Thanks for your inquiry. Unfortunately, there is no way to get old
versions of Aspose.Words. Our internal policy does not allow us to share
versions of products older than one year. You can get only version of
Aspose.Words that is not older than one year.

Regarding the exception using create assembly in SQL Server 2008 R2, I have logged this issue as WORDSNET-10761 in our issue tracking system. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

I sure hope I have misunderstood you.


Our company has been a customer of yours since 2011. We have renewed our subscription regularly until now. Are you saying you refuse to allow me to download a product I have already paid for? Are you saying I am no longer entitled to use the product I purchased from you in 2011?

I am trying to revert back to an older version of this product because of what appears to be a bug in your code and you say I can’t use a version older than 1 year? What I end up finding by testing older dlls may actually help you with the diagnosis of this issue!

I hope this is just a misunderstanding because it doesn’t even sound legal to me. Depending on your response, I will be checking with my company’s legal department.

Hi Mike,


Thanks for your inquiry. As we state in our EULA, and in particular the following instruction:
5. SOFTWARE DELIVERY:
The
Product and any associated materials are provided in electronic format
only. You are responsible for downloading the Product from the Aspose
website: http://www.aspose.com.
Upon purchase, Aspose shall deliver to You an electronic license file
which will enable the Product to function in the purchased license
capacity. Previous versions of the Product will only be available for a
twelve (12) month period from the date of publishing; access to previous
versions once removed will only be available to customers who hold a
current subscription for the Product. CUSTOMERS ARE ADVISED TO KEEP A BACKUP COPY OF ANY DOWNLOADED SOFTWARE FOR FUTURE USE.

As
you will see, it is not actually possible for you to download an older
version of Aspose.Words that is published more than 12 months ago; so
regretfully you don’t have permissions to re-download such releases from
our website.

The solution would be to renew your subscription; i.e. once you have a valid subscription, we can then send you the required old release of Aspose.Words. For renewing/upgrading a subscription, please contact our sales team via Aspose.Purchase forum.

Moreover, you can check the expiration date of your license by opening the license file in notepad. There, you will see the following tag:

20110218

It means that you can free upgrade to a version of Aspose.Words that is published before 02/18/2011.

Please let me know if I can be of any further assistance.



Hi Mike,

Thanks for your patience. I have received response from our product team about issue WORDSNET-10761. They are unable to reproduce this issue at their end. Please use Aspose.Words for .NET 15.6.0 and let us know if you have any more queries.