Free Support Forum - aspose.com

WordWrap messes up cell

Hi!

I have attached a sample application that shows you the problem. What it does is:

.) Open the input file
.) Write long text into the first cell
.) Set AutoWrap of that cell to true and give it an indent
.) Write text into the second cell
.) Set AutoWrap of that cell to true and give it an indent
.) AutoFitColumn of first column
.) Write output file

If you then look at the output file, you will see that even though I have autofitted the first column, it creates a weird empty line within that cell that I cannot erased. If you perform the same steps in Excel manually, everything works as expected.

Kind Regards and thanks in advance,
BerndAspose.WordWrapBug.zip (4.8 MB)

@bernd.podhradsky,

We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46417 - Wrap text not working along with an empty line above the text

@bernd.podhradsky,

Could you please share a file as your expected output so that we can investigate this issue accordingly.

@bernd.podhradsky,

Please try our latest version/fix: Aspose.Cells for .NET v18.10.3 (attached):

Your issue should be fixed in it.

Let us know your feedback.
Aspose.Cells18.10.3 For .Net2_AuthenticodeSigned.Zip (4.7 MB)
Aspose.Cells18.10.3 For .Net4.0.Zip (4.7 MB)

Unfortunately when running the test application provided by me in the first post of this thread with the new version, the problem stills persists.

Bernd

@bernd.podhradsky,

I have reopened the issue for further analysis. Once, we will have some news for you, we will update you in this topic.

@bernd.podhradsky,

Please try our latest version/fix: Aspose.Cells for .NET v18.10.7:

Aspose.Cells18.10.7 For .Net2_AuthenticodeSigned.Zip (4.7 MB)
Aspose.Cells18.10.7 For .Net4.0.Zip (4.7 MB)

Your issue should be fixed in it.

Let us know your feedback.

Hi!

18.10.7 fixes the issue!

Thanks,
Bernd

@bernd.podhradsky,

Good to know that your issue is sorted out by the new fix/version. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

I have the same problem, I also want to obtain that dll, can you help me? thanks

@bizagi-engineering,

You may please download the Aspose.Cells for .NET v18.10.7 Dlls here:

Aspose.Cells18.10.7 For .Net2_AuthenticodeSigned.Zip (4.7 MB)
Aspose.Cells18.10.7 For .Net4.0.Zip (4.7 MB)

Sorry, the links are private. How i can get access to this dlls

Thank you

@alejo491,

You may please try to download it from the following dropbox links:

The issues you have found earlier (filed as CELLSNET-46417) have been fixed in Aspose.Cells for .NET v18.11. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi