We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Wrong DeliveryTime in Mail sent by Macro

Hello,


I have a problem regarding MapiMessages. We try to read DeliveryTime from a MapiMessage, which was sent through a Macro in Excel.

When I view the mail in MFCMAPI, the PR_MESSAGE_DELIVERY_TIME is correct, but your Framework says, that it’s “Sat Jan 01 00:00:00 CET 1” - why?

You find an example as attachment to this post.

Thanks in advance

Andi

Hi Andi,


Thank you for writing to Aspose support team.

I have analyzed the message and observed its properties in MFCMapi, however I could not find the PR_MESSAGE_DELIVERY_TIME property. You may confirm if you have sent us the right message or not and share the version of MFCMapi used in your testing. Also send us the snapshot of the MFCMapi showing this property for the same message.

I’m Sorry. My fault. I took the wrong message. So I have to find out, why there is no delivery time in those messages…

Best Regards

Andi

Hi Andi,


Please feel free to write to us when you have got hold of the accurate messages in this regard.

Andi, please tell what you have done to solve the problem? if you have solved it at all. the reason I ask is that I have something similar to that so maybe you could help me now?

Hi,


If you have any such sample file that posses this issue, you can share it with us here so that we can investigate it further at our end. We’ll look into it for assisting you further.

In our mail there is no delivery time if I search for it with MFCMAPI. So Aspose cannot read ist. We took another solution for this…

Hi Andreas,


Thank you for the feedback. Please feel free to write us back if you have any other query related to Aspose.Email.