Free Support Forum - aspose.com

Wrong Plan start and end dates appearing on exporting MPP (C# .NET)

Hi Team,

After exporting to mpp the Plan start and Plan end are not showing the actual dates from the original data. Please find the attachments.ExportPlan.zip (64.8 KB)

Note: I tried the above code with Aspose.Tasks 19.12 latest version

Regards,
Ravi

@ravikonnur,

I have worked with sample project shared. An issue with ID TASKSNET-3722 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Hi Team,

Please provide the solution for the above issue as earliest.

Thanks,

@ravikonnur,

I have verified from our issue tracking system and regret to share that at present the issue is unresolved. We request for your patience till the time the issue gets resolved and feedback is shared.

@ravikonnur We prepared a sample with Aspose.Tasks for .NET 20.1, please check it out:

TASKSNET-3722.zip (4.7 KB)

But we don’t see the incorrect dates in the output file. What exactly data is incorrect in this case?

Hi Team,

I checked with your sample there ResourceAssignments is not there so its working fine, But with ResourceAssignments its showing incorrect dates in Plan Start and Plan End.Please find the attached code sample. ExportPlan.zip (56.0 KB)

Regards,
Ravi

@ravikonnur,

Thank you for sharing the feedback. I have associated the information in our issue tracking system and will get back to you with feedback as soon as possible.

@ravikonnur
Please check the next updated example.
TASKSNET-3722-ver2.zip (6.0 KB)

Hi Team,
I wanted to know that, Is this sample code work for 19.12 version.

Regards,
Ravi K

@ravikonnur,

I have verified from our issue tracking system and like to share that it has been marked as fixed in upcoming Aspose.Tasks for .NET 20.2. We will share the notification with you as soon as the product will be available online.