We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

XLSX files take much more time to load than XLS

Hello.


In my project, we’ve recently upgraded all our Excel reports’ templates from XLS to XLSX.

Once a month, we run a Java application (which uses Aspose.Cells) that generates one or more reports for each client, based on their requests, and we e-mail them to the clients.

One of these reports is a lot bigger than the others, it has reached 100+ sheets recently, and it’s the one we send the most to our clients. Since the migration from XLS to XLSX format, we found that the application is taking a lot longer to finish (from 2 1/2 hours to 12 hours). While before this report would take about 16 seconds to load into memory, now it takes more than 1 minute.

We’ve tried using XLSB format, but the time didn’t improve much and some graphs were having problems, or were not being shown.

We’ve also tried using a “cloning” JAR from Apache, which clones objects in memory. This way, we only had to load the template once, and we’d copy the memory object. We got back to the 16 seconds, but we still had esthetical problems in the final reports.

Is there some optimization that can be done on Aspose.Cells, in order to significantly improve the loading times of XLSX files?

Thanks

Hi,

Thanks for your posting and using Aspose.Cells for Java.

Please download and try the latest version Aspose.Cells
for Java v7.5.1.3
and see if it resolves your issue.

If your issue still occurs, please provide us your runnable sample project and source files to investigate this issue. We will look into it and update you asap.

Hi,

I am not an Aspose employee just another user like yourelf. We had an issue with very slow opening Excel files which was due to the Excel Add Ins which had a cumulated over time.

Removing / disbling them solved the problem for us.

http://office.microsoft.com/en-us/excel-help/add-or-remove-add-ins-HP010342658.aspx

Regards

Geoff.

Hello,


motoway, thank you very much for your input. I don’t know if we use any add-ins, but I’ll be sure to check soon.

If it is not the problem, then I’ll provide a sample and an XLSX template to show how slow it is.

Have a nice day,
Pedro

Hello again,


motoway, it turns out we don’t use any add-ins on our documents. But I appreciate your willingness to help.

Shakeel, I’ve downloaded the latest version of Aspose.Cells (7.5.1), and it’s running really well! 6 seconds to load our biggest report.

I guess this post can be closed now.

Have a nice day,
Pedro

Hi,

Thanks for your feedback and using Aspose.Cells for Java.

It is good to know that your issue is resolved with the latest version. We have closed this thread now. If you encounter any other issue, please feel free to post on our forums. We will be glad to help you further.