Free Support Forum - aspose.com

Aspose.Imaging keeps adding watermark even when licensed

Hi,

I have a license for Aspose.Total expiring at 2020/06/21 so my understanding is that I should be able to license any version up to 20.6 of any Aspose component in my project.

However, Aspose.Imaging keeps adding the watermark on my converted images.
I also use Aspose.Words and Aspose.Mail which are working fine with the license.
I do call the ‘SetLicense’ method for all 3 components I use so I’m pretty sure the issue is not coming from the code.
I also tried to call ‘SetLicense’ :

  • with the name of the license, available in the Embedded resources
  • with the full path to the license
  • with a FileStream pointing to the license file

None of the above worked.
Also, I stumbled upon this topic which seems to be closely related to my issue :


Because of security issues at my company I can not use the solution proposed in this post.

Can you help me ?
Thanks

1 Like

I also cannot use the provided solution due to security restrictions.

Given the appropriate approvals and reviews I could potentially bypass the Nuget, but we are blocked from accessing drive.google.com, gmail.com or any other site that could potentially result in data leakage.

@mcrose

Actually, we have made a special hotfix only for special cases whose subscription was going to expire in June/July 2020 and they intended to use Aspose.Imaging for .NET 20.6 which was in fact a valid version for their subscription. Therefore a special hotfix was developed for certain people only as it was not the case for all customers. Therefore, we have not published it anywhere and request you to please download the appropriate version as per your license expiry date limit from this link.

@mudassir.fayyaz
Actually, I cannot download software from google drive due to security protocols put in place by the bank I work for.

I hear what you are saying but understand that this solution is not ideal on our side.
Would it be conceivable to work on a different solution ?

Thanks for your time

@ribollet.genapi.fr

What other solution will be feasible for you. We may not post this on Nuget too at this point of time as there is Aspose.Imaging for .NET 20.10 being latest there.

A new license file that works with 20.10 would be good.

@mcrose

I may help you with technical issues related to API and the issue that you have reported has already been fixed in the form of special hotfix addressing this issue. You may consult our sales team in Aspose.Purchase support forum for new license granting issue.

Thank you!
I will contact our License Management department and see if they can make something happen.

@mcrose

Thank you for your understanding here.