We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose license problems

We have been using Aspose.Cells for Java for a project for a couple of years.

Now, the license file isn’t working - when we run, we get:

com.aspose.cells.CellsException: The license is invalid. The signature is invalid.
at com.aspose.cells.License.setLicense(Unknown Source)
at com.accius.qt.xls.AsposeLicense.(AsposeLicense.java:68)
at com.accius.qt.xls.AsposeLicense.init(AsposeLicense.java:90)

errors. We recently upgraded to java 1.6 - is this causing a problem? We are also trying it on vista - could this be causing a problem?


Hi,

Thanks for providing us some details.

We have tested Aspose.Cells for Java license file on Vista with JDK 1.6 and it works fine.

Could you post us your license file, we will check your issue soon. Note: To post your license file to use, just follow the steps given @: http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx Please do confirm us here (in this thread) when you have sent your mail with license file (as an attachment).

Thank you.

I have sent the license file.

thanks for your attention to this.

Hi,

Thanks, we have received your license file. We will check your issue (on Vista with JDK 1.6) and get back to you soon.

By the way, I have checked your license file a bit, its expiry date is June 16, 2007. So, may I know which version of Aspose.Cells for Java you are using with this license file using JDK 1.6 on Windows Vista. It is to be noted here, you need to upgrade your subscription if you want to use any Java version released after your subscription expiry date.

Thank you.

It sounds like you are saying the resolution is to upgrade - is that true?

Is that just the same as getting a new license, or is there an upgrade path we can take?

Hi,

Well, we have tested your license file with our latest fix on Vista with JDK1.6 and it works fine. It gives only subscription expiry error which it should :)

Could you try your license file with the latest version on your environment. -----> If you find only the subscription expiry error and no more signature error, kindly upgrade your subscription then. To upgrade your subscription, please post your query @ Aspose.Purchase forum : http://www.aspose.com/community/forums/aspose.purchase/220/showforum.aspx and one of our sales staff member will help you soon.

Thank you.

Hi,

And kindly find attached the latest fix for Aspose.Cells for Java, could you try it.

Thank you.

Is the subscription expire warning the evaluation only page that gets attached to the sheet? that’s what I get with the new version and the old license file.

if it’s supposed to throw an actual exception, it’s not doing that.

Hi,

Yes, I think you need to upgrade your subscription.

Thank you.