We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Words Spell Check resulting document

Hi,

This post is based on Issue 4599. I have searched the site, and also in the release notes for each version and can’t find any mention of this Issue being resolved.

I have come up with a work around for this issue (previously posted) by setting the Font.Locale for each run to the language required by the client.

This works and spell check within the run works, and MS WORD highlights spelling errors etc as you type.

BUT,

When typing outside of existing runs in a document generated using Aspose.Words, you can spell check the text just entered until you have selected the text and set its language.

I have tried setting the locale at various levels in the document, but the results are still the same (i.e I can spell check within existing runs only)

How do I set the Locale for the entire document, so that if I add text outside of existing runs MS WORD will spell check the text for me without having to set the language in MS WORD. This is a client requirement, and having to set the language manually as described above is not acceptable.

Hi

Thanks for your request. The issue #4599 is not resolved yet. Maybe you should try using code like the following to change LocaleId of an entire document.

// Open document

Document doc = new Document(@“Test171\in.doc”);

// Create visitor

// 1049 - is Russian

LocaleChanger visitor = new LocaleChanger(1049);

// Accept visitor that will change locale

doc.Accept(visitor)

// Save output document

doc.Save(@“Test171\out.doc”);

LocaleChanger class is attached.

Hope this helps.

Best regards.

Hi,

I implemented the code provided, and ran a quick test, and spell check functionality works.

Thank you very much

Hi Alexey,

i have tried to use your code but my problem still persist!

I mean, I have a Word file, open it with Aspose.Words and I go to change it.

After I saved the file (even with the LocaleChanger) and tried to open it with Word, Word automatically closes.

I investigated and the problem seems to be in the spell check in Word.

Any ideas?

Thanks!

Andrea

Hi Andrea,

Thanks for your inquiry. Could you please attach your documents here for testing (input and output) and provide me simple code, which will allow me to reproduce the problem? I will check the issue on my side and provide you more information.

In addition, step-by-step guidance how I can reproduce the problem on my side will help me a lot.

Best regards.

Hi,

I hope you will find a solution…

thanks!

Andrea

Hi

Thank you for additional information. I cannot reproduce the problem on my side. I tried opening your output document using MS Word 2000, 2002 (XP), 2002 SP3, 2003, 2003 SP3 and 2007. All versions of MS Word open your output document without any issues.

Which versions of MS Word and Aspose.Words do you use? To check version of Aspose.Words, right click on the dll, select Properties from the context menu, then select Version tab. You will see File version.

Maybe, you should try using the latest version of Aspose.Words. You can download it from here:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

Best regards.

The issues you have found earlier (filed as WORDSNET-1586) have been fixed in this Aspose.Words for .NET 17.6 update and this Aspose.Words for Java 17.6 update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.